Bug 757712 - grub2 keeps booting old kernel after updating to newer one
grub2 keeps booting old kernel after updating to newer one
Status: CLOSED DUPLICATE of bug 732058
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
16
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-28 08:36 EST by Alexander van Loon
Modified: 2011-11-28 12:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-28 12:01:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my grub2.cfg (3.84 KB, text/plain)
2011-11-28 08:36 EST, Alexander van Loon
no flags Details

  None (edit)
Description Alexander van Loon 2011-11-28 08:36:20 EST
Created attachment 537472 [details]
my grub2.cfg

Description of problem:

I was requested to open a new bug in bug #732058. I did a clean install of the Fedora 16 x86-64 GNOME Live CD and noticed that after it pulled in a new kernel (3.1.2-1) through the updates, it still kept booting the old kernel (3.1.0-7 according to uname -a). My /etc/default/grub looks like this:

GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR="Fedora"
GRUB_DEFAULT=saved
GRUB_CMDLINE_LINUX_DEFAULT="i8042.reset=1"
GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0  KEYTABLE=us-acentos LANG=en_US.UTF-8"

All I did was change the timeout to 0 so I wouldn't get the menu and add i8042.reset=1 to work around a kernel bug which prevents my notebook from properly returning after it is suspended. Nothing else as far I know. My grub.cfg is attached as requested.
Comment 1 Mads Kiilerich 2011-11-28 09:33:58 EST
That grub.cfg is not the one you had after installing the kernel. You must have created a new boot loader configuration with grub2-mkconfig. Can you confirm that?
Comment 2 Alexander van Loon 2011-11-28 10:38:55 EST
That is correct, I did use grub2-mkconfig because otherwise my two modifications to /etc/default/grub wouldn't have been picked up, right?
Comment 3 Mads Kiilerich 2011-11-28 12:01:14 EST
Ok, that crucial information makes it the same bug anyway.

*** This bug has been marked as a duplicate of bug 732058 ***

Note You need to log in before you can comment on or make changes to this bug.