Bug 75784 - Installing new up2date-2.8.39-1.7.3 package fails to replace some files
Summary: Installing new up2date-2.8.39-1.7.3 package fails to replace some files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-12 11:11 UTC by Doug
Modified: 2015-01-08 00:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-14 15:45:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test case for this bug (170 bytes, text/plain)
2002-11-04 23:11 UTC, Adrian Likins
no flags Details

Description Doug 2002-10-12 11:11:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; T312461)

Description of problem:
When using up2date (the previous version installed with RedHat 7.3) to get the 
newest update (2.8.39-1.7.3), some files in /etc/sysconfig/rhn remain 
unchanged, and new files with *.rpmnew suffixes are inserted into the directory.

This may be because up2date was in-use when it tried to update itself.  Or, it 
may be that the new up2date doesn't want to brute-force overwrite these files.

Oh, the files are rhn_register, rhnsd, and up2date, all in /etc/sysconfig/rhn, 
and all original files are non-updated but all files have new *.rpmnew suffixes.

This MAY be by design, but nothing in the up2date process suggested that I 
should overwrite these files with the new ones, or if I should just leave the 
new files as-is.  The update process *DID* warn that it was creating the 
*.rpmnew files, but it did not give any clues as to their final dispositions.


Version-Release number of selected component (if applicable):
up2date-2.8.39-1.7.3

How reproducible:
Didn't try

Steps to Reproduce:
1. Install RedHat 7.3, ensuring that up2date is install.
2. Setup up2date, register, etc.
3. Do the update with "up2date -u"
4. (Notice warning messages)
5. Check in /etc/sysconfig/rhn to see if the above mentioned files have been 
updated or if they are new with *.rpmnew suffixes.
	

Actual Results:  Original files rhnsd, rhn_register, and up2date remain non-
updated, but new files with *.rpmnew suffixes exist instead.

Expected Results:  Shouldn't the files rhnsd, rhn_register, and up2date have 
been updated?  Running an "rpm -V up2date" indicates that these files are NOT 
matching the update.

Additional info:
This may NOT actually be a bug, but an "un-documented user expectation".  :)   
That is, should the user (like me) manually update these files, or should they 
remain as-is, with the new *.rpmnew names?

The update was part of a recent RHN errata package, RHBA-2002:140-25.

Comment 1 Adrian Likins 2002-10-18 21:21:00 UTC
More or less thats whats supposed to happen. The next version wont
have the files marked noreplace however, so there shouldnt be
.rpmnew's with the next version.

Comment 2 Adrian Likins 2002-11-04 23:07:55 UTC
version 2.8.39 or 3.0.15 or higher (seperate branches) should
include this fix.

Comment 3 Adrian Likins 2002-11-04 23:11:18 UTC
Created attachment 83584 [details]
test case for this bug

Comment 4 Jay Turner 2003-02-14 15:45:30 UTC
Fix confirmed with up2date-3.1.15-7.


Note You need to log in before you can comment on or make changes to this bug.