Bug 757985 - need corrections in ur.orth file
Summary: need corrections in ur.orth file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-29 06:09 UTC by Pravin Satpute
Modified: 2012-06-11 12:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-11 12:01:12 UTC
Type: ---


Attachments (Terms of Use)
patch to fix urdu orth file (444 bytes, patch)
2011-11-29 06:09 UTC, Pravin Satpute
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 43321 None None None Never

Description Pravin Satpute 2011-11-29 06:09:09 UTC
Created attachment 537790 [details]
patch to fix urdu orth file

Description of problem:
We have recently packaged Urdu fonts from
http://www.crulp.org/software/localization.htm in Fedora. These fonts are
actively used for creating content in Urdu language from 5+ years.

fontconfig do not recognize them as complete font for urdu language due to
missing characters

U+0629 ARABIC LETTER TEH MARBUTA
U+0647 ARABIC LETTER HEH

I have got following response from upstream

" Alternate codes are recommended for Urdu
by Unicode standard itself (see the code-wise text explanation after
the code chart at http://www.unicode.org/charts/PDF/U0600.pdf for
U+06C3 as an alternate to U+0629 and U+06BE (or U+06C1; depends on
which Heh one is referring to) as an alternate to U+0647)."

Page 5 In Arabic code U+0600 Unicode chart 6.0 gives
U+06C3  "ARABIC LETTER TEH MARBUTA GOAL, Urdu"
U+06BE "ARABIC LETTER HEH DOACHASHMEE, Urdu"

So,
U+06C3 is recommended by Unicode instead of U+0629
U+06BE is recommended by Unicode instead of U+0647


Version-Release number of selected component (if applicable):
fontconfig-2.8.0-4.fc16.x86_64

How reproducible:
everytime

Steps to Reproduce:
1. yum install nafees-*
2. fc-query /usr/share/fonts/nafees-naskh/Nafees\ Naskh\ v2.01.ttf
3. it gives lang: (s)
  
Actual results:
lang: (s)

Expected results:
lang: ur(s)

Additional info:
attached patch

Comment 1 Fedora Admin XMLRPC Client 2012-01-10 15:42:31 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Pravin Satpute 2012-02-14 14:47:06 UTC
This bug part of Fedora 17 feature
https://fedoraproject.org/wiki/Features/Additional_Indic_Langs

Comment 3 Pravin Satpute 2012-03-13 05:41:56 UTC
upstream fontconfig 2.9.0 release is available with this fix http://lists.freedesktop.org/archives/fontconfig/2012-March/003811.html

Comment 4 Fedora Admin XMLRPC Client 2012-03-22 01:37:56 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Fedora Update System 2012-03-23 06:58:05 UTC
fontconfig-2.8.0-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fontconfig-2.8.0-6.fc17

Comment 6 Fedora Update System 2012-04-12 02:16:13 UTC
fontconfig-2.8.0-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.