Bug 758045 - [abrt] libreoffice-core-3.4.4.2-2.fc16: Process /usr/lib/libreoffice/program/soffice.bin was killed by signal 6 (SIGABRT)
[abrt] libreoffice-core-3.4.4.2-2.fc16: Process /usr/lib/libreoffice/program/...
Status: CLOSED DUPLICATE of bug 752220
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eike Rathke
Fedora Extras Quality Assurance
abrt_hash:12aa8f3b18606c14739f1179ffc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-29 04:21 EST by Andrey Arapov
Modified: 2012-01-11 07:31 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-11 07:31:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: event_log (3.23 KB, text/plain)
2011-11-29 04:21 EST, Andrey Arapov
no flags Details
File: dso_list (23.32 KB, text/plain)
2011-11-29 04:21 EST, Andrey Arapov
no flags Details
File: environ (2.41 KB, text/plain)
2011-11-29 04:21 EST, Andrey Arapov
no flags Details
File: smolt_data (3.54 KB, text/plain)
2011-11-29 04:21 EST, Andrey Arapov
no flags Details
File: maps (55.72 KB, text/plain)
2011-11-29 04:21 EST, Andrey Arapov
no flags Details
File: backtrace (58.02 KB, text/plain)
2011-11-29 04:21 EST, Andrey Arapov
no flags Details

  None (edit)
Description Andrey Arapov 2011-11-29 04:21:42 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 3
cmdline:        /usr/lib/libreoffice/program/soffice.bin --calc file:///home/arno/Downloads/nmon%20analyser%20v33g.xls --splash-pipe=7
executable:     /usr/lib/libreoffice/program/soffice.bin
kernel:         3.1.1-2.fc16.i686.PAE
pid:            28469
pwd:            /home/arno
reason:         Process /usr/lib/libreoffice/program/soffice.bin was killed by signal 6 (SIGABRT)
time:           Thu 24 Nov 2011 04:49:54 PM CET
uid:            1000
username:       arno
var_log_messages: Nov 24 16:49:55 fedora abrt[28672]: Saved core dump of pid 28469 (/usr/lib/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-11-24-16:49:54-28469 (126070784 bytes)
xsession_errors: 

backtrace:      Text file, 59412 bytes
dso_list:       Text file, 23881 bytes
environ:        Text file, 2467 bytes
event_log:      Text file, 3311 bytes
maps:           Text file, 57054 bytes
smolt_data:     Text file, 3621 bytes
Comment 1 Andrey Arapov 2011-11-29 04:21:49 EST
Created attachment 537837 [details]
File: event_log
Comment 2 Andrey Arapov 2011-11-29 04:21:51 EST
Created attachment 537838 [details]
File: dso_list
Comment 3 Andrey Arapov 2011-11-29 04:21:53 EST
Created attachment 537839 [details]
File: environ
Comment 4 Andrey Arapov 2011-11-29 04:21:55 EST
Created attachment 537840 [details]
File: smolt_data
Comment 5 Andrey Arapov 2011-11-29 04:21:57 EST
Created attachment 537841 [details]
File: maps
Comment 6 Andrey Arapov 2011-11-29 04:21:59 EST
Created attachment 537842 [details]
File: backtrace
Comment 7 Caolan McNamara 2011-11-29 04:35:16 EST
Unfortunately, the backtrace isn't very useful in this case. Are you able to reproduce this bug ?, was it opening a specific .xls document ?, if so can you attach the crashing document here ?
Comment 8 Andrey Arapov 2011-11-29 05:11:34 EST
Yes, this bug is reproducible.

- Open "nmon analyser v33g.xls" file
OK
- Tools -> Macros -> Run Macro
- navigate:
  nmon analyser v33g.xls
    VBAProject
      ThisWorkbook
        Workbook_Open  (select this Macro)
- Click "Run" button
nothing will happen, ok.
- Just close Libre Office

wait 3-8 seconds and you will see abrt logged crash
"A Problem has Occured"

Caolan - I will send you "nmon analyser v33g.xls" file via Email.
Comment 10 Eike Rathke 2012-01-10 13:19:00 EST
@sbergman: an idea what could be going on there?

I first get a "BASIC syntax error. Symbol expected." that opens the BASIC editor. After having run the macro and closed the application (invoked from the command line) there's

# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00000039ec009db4, pid=9912, tid=140623736706880
#
# JRE version: 6.0_22-b22
# Java VM: OpenJDK 64-Bit Server VM (20.0-b11 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea6 1.10.4
# Distribution: Fedora release 16 (Verne), package fedora-61.1.10.4.fc16-x86_64
# Problematic frame:
# C  [libpthread.so.0+0x9db4]  pthread_mutex_lock+0x4
#
# An error report file with more information is saved as:
# $HOME/hs_err_pid9912.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
#

The hs_err_pid*.log in the register to memory mapping contains
RDX=0x00000039efa5a720: <offset 0x25a720> in /usr/lib64/libreoffice/program/../basis-link/ure-link/lib/libuno_sal.so.3 at 0x00000039ef800000
and lots of libreoffice libs in process data.
Comment 11 Stephan Bergmann 2012-01-11 03:02:39 EST
I get the BASCI syntax error message, too.  The JRE report is just due to a JVM having been instantiated in the soffice.bin process (which happens upon "Tools - Macros - Run Macro"). taking over reporting of all SIGSEGVs, not just JVM-related ones.  Attaching gdb show that with LO 3.4.4 in F-16, the crash is at

#0  __pthread_mutex_lock (mutex=0x37ea25a720) at pthread_mutex_lock.c:51
#1  0x00000037ea015000 in osl_acquireMutex (Mutex=<optimized out>) at mutex.c:130
#2  0x00007fc64083d37c in EventGuardAcquire (this=<optimized out>) at ../../../unx/inc/plugins/gtk/gtkdata.hxx:83
#3  GtkXLib::userEventFn (data=0x7fc6423dd8c8) at /usr/src/debug/libreoffice-3.4.4.2/vcl/unx/gtk/app/gtkdata.cxx:800
#4  0x00007fc63e56ea7d in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#5  0x00007fc63e56f278 in ?? () from /lib64/libglib-2.0.so.0
#6  0x00007fc63e56f44c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#7  0x00007fc64083ad19 in GtkXLib::Yield (this=0x7fc6423dd8c8, bWait=true, bHandleAllCurrentEvents=<optimized out>)
    at /usr/src/debug/libreoffice-3.4.4.2/vcl/unx/gtk/app/gtkdata.cxx:868
#8  0x00007fc64083b376 in GtkXLib::~GtkXLib (this=0x7fc6423dd8c8, __in_chrg=<optimized out>)
    at /usr/src/debug/libreoffice-3.4.4.2/vcl/unx/gtk/app/gtkdata.cxx:577
#9  0x00007fc64083b439 in GtkXLib::~GtkXLib (this=0x7fc6423dd8c8, __in_chrg=<optimized out>)
    at /usr/src/debug/libreoffice-3.4.4.2/vcl/unx/gtk/app/gtkdata.cxx:587
#10 0x00007fc63e2e682a in X11SalData::DeleteDisplay (this=0x7fc640ca3970)
    at /usr/src/debug/libreoffice-3.4.4.2/vcl/unx/source/app/saldata.cxx:293
#11 0x00007fc63e2e685b in X11SalData::~X11SalData (this=0x7fc640ca3970, __in_chrg=<optimized out>)
    at /usr/src/debug/libreoffice-3.4.4.2/vcl/unx/source/app/saldata.cxx:286
#12 0x00007fc64083aaa3 in ~GtkData (this=0x7fc640ca3970, __in_chrg=<optimized out>)
    at /usr/src/debug/libreoffice-3.4.4.2/vcl/unx/gtk/app/gtkdata.cxx:1032
#13 GtkData::~GtkData (this=0x7fc640ca3970, __in_chrg=<optimized out>)
    at /usr/src/debug/libreoffice-3.4.4.2/vcl/unx/gtk/app/gtkdata.cxx:1034
#14 0x00007fc63e2f1dc9 in X11SalInstance::~X11SalInstance (this=0x7fc640cfeda0, __in_chrg=<optimized out>)
    at /usr/src/debug/libreoffice-3.4.4.2/vcl/unx/source/app/salinst.cxx:141
#15 0x00007fc64083d799 in GtkInstance::~GtkInstance (this=0x7fc640cfeda0, __in_chrg=<optimized out>)
    at /usr/src/debug/libreoffice-3.4.4.2/vcl/unx/gtk/app/gtkinst.cxx:190
#16 0x00000037ecb77806 in DestroySalInstance (pInst=0x7fc640cfeda0)
    at /usr/src/debug/libreoffice-3.4.4.2/vcl/unx/source/plugadapt/salplug.cxx:264
#17 0x00000037ec90b4ec in DeInitVCL () at /usr/src/debug/libreoffice-3.4.4.2/vcl/source/app/svmain.cxx:566
#18 0x00000037ec90ba40 in ImplSVMain () at /usr/src/debug/libreoffice-3.4.4.2/vcl/source/app/svmain.cxx:198
#19 0x00000037ec90bb25 in SVMain () at /usr/src/debug/libreoffice-3.4.4.2/vcl/source/app/svmain.cxx:211
#20 0x00000037f0c46905 in soffice_main () at /usr/src/debug/libreoffice-3.4.4.2/desktop/source/app/sofficemain.cxx:67
#21 0x0000000000400dbb in sal_main () at main.c:36
#22 main (argc=<optimized out>, argv=<optimized out>) at main.c:35

I cannot reproduce the crash with current LO master towards LO 3.6 (it exits cleanly there)---is this a known gtk issue that has been fixed meanwhile?
Comment 12 David Tardon 2012-01-11 07:15:35 EST
dtardon->sbergman: yes, this stack is bug 752220
Comment 13 Stephan Bergmann 2012-01-11 07:31:08 EST

*** This bug has been marked as a duplicate of bug 752220 ***

Note You need to log in before you can comment on or make changes to this bug.