Bug 75809 - make modules error
make modules error
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
athlon Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-10-12 17:22 EDT by MH
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-03-25 19:26:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description MH 2002-10-12 17:22:03 EDT
Description of Problem: 
After performing a clean install of RH 8.0 I got the following "make" error 
when attempting to compile a custom kernel: 
make[2]:***[loop.0] Error1 
make[2]: Leaving directory '/usr/src/linux-2.4.18-14/drivers/block' 
make[1]:***[_modsubdir_block] Error 2 
make[1]: Leaving directory '/usr/linux-2.4.18-14/drivers' 
make:***[_mod_drivers] Error 2 
I tried reconfiguring the kernel without the "loopback" module then 
recompiling. I got the same type of error, albeit with reference to a 
different module. 
Version-Release number of selected component (if applicable): 
How Reproducible: 
Compile a custom kernel 
Steps to Reproduce: 
1. make dep  
2. make bzImage 
3. make modules 
Actual Results: 
Error and program termination 
Expected Results: 
Successful compilation of modules 
Additional Information:
Comment 1 Brian Brock 2002-10-17 17:20:16 EDT
Please prepend `make mrproper` to your list of build steps (even before any
configuration steps), and also include here the steps that you're using to
configure the kernel build.

Setting compontent to kernel, this looks like an issue specific to the
kernel-source package, not to make.
Comment 2 Arjan van de Ven 2002-10-18 06:58:05 EDT
need a few more lines above the error...
Comment 3 bill 2002-10-28 21:54:17 EST
I installed redhat-8 + the new kernel (2.4.18-17) kernel + source.  I
had the same problem, a CIPE related source file, an ATM related source
file, and the loop related source file all failed to build with a fatal
error.  make mrproper fixed this for me.  
Comment 4 Gerald Teschl 2002-12-05 08:43:29 EST
I just tried to compile a 2.4.18-18.8.0 and get the same erros (CIPE module)

If I do a "make mrproper" before the compile it will fail to do "make dep"
rigth at the begining.

To reproduce.
1) install kernel-source
2) make mrproper
3) cp configs/kernel-2.4.18-i686.config .config
4) make dep

results in
[root@soliton linux-2.4.18-18.8.0]# make dep
make[1]: Entering directory `/usr/src/linux-2.4.18-18.8.0/arch/i386/boot'
make[1]: Nothing to be done for `dep'.
make[1]: Leaving directory `/usr/src/linux-2.4.18-18.8.0/arch/i386/boot'
scripts/mkdep -- init/*.c > .depend
scripts/mkdep -- `find /usr/src/linux-2.4.18-18.8.0/include/asm
/usr/src/linux-2.4.18-18.8.0/include/math-emu -name SCCS -prune -o -follow -name
\*.h ! -name modversions.h -print` > .hdepend
find: /usr/src/linux-2.4.18-18.8.0/include/asm: No such file or directory
find: /usr/src/linux-2.4.18-18.8.0/include/math-emu: No such file or directory
make _sfdep_kernel _sfdep_drivers _sfdep_mm _sfdep_fs _sfdep_net _sfdep_ipc
_sfdep_lib _sfdep_abi _sfdep_crypto _sfdep_arch/i386/kernel _sfdep_arch/i386/mm
_sfdep_arch/i386/lib _FASTDEP_ALL_SUB_DIRS="kernel drivers mm fs net ipc lib abi
crypto arch/i386/kernel arch/i386/mm arch/i386/lib"
make[1]: Entering directory `/usr/src/linux-2.4.18-18.8.0'
make -C kernel fastdep
make[2]: Entering directory `/usr/src/linux-2.4.18-18.8.0/kernel'
make[2]: *** No rule to make target
`/usr/src/linux-2.4.18-18.8.0/include/linux/autoconf.h', needed by
`/usr/src/linux-2.4.18-18.8.0/include/linux/modules/signal.ver'.  Stop.
make[2]: Leaving directory `/usr/src/linux-2.4.18-18.8.0/kernel'
make[1]: *** [_sfdep_kernel] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.18-18.8.0'
make: *** [dep-files] Error 2
Comment 5 Arjan van de Ven 2002-12-05 08:51:49 EST
To reproduce.
1) install kernel-source
2) make mrproper
3) cp configs/kernel-2.4.18-i686.config .config
4) make dep

you forgot a "make oldconfig" (or xconfig or menuconfig etc) between steps 3 and 4
Comment 6 Brian Brock 2003-03-25 19:26:18 EST
I've tested all of the above, and following the full set of steps suggested by
Arjan results in a sane build.  Resolving as not a bug, the kernel-source
package behaves as intended.

Note You need to log in before you can comment on or make changes to this bug.