Bug 75819 - Memos Command Deletes Unspecified Last Memo
Memos Command Deletes Unspecified Last Memo
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: pilot-link (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-12 21:45 EDT by Thomas Smith
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:04:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Smith 2002-10-12 21:45:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
The use of the -d option for memos deletes the last memo when no number is
specified.  This is apt to occur because the -s switch is used for writing memos
to a directory rather than -d, which does deletion.  This is different than most
command line tools, where -d deals with directories. Thus a user wanting to
write the memos to the current directory, who makes the mistake of using the -d
switch meaning directory instead of deletion, will have no memos written and the
last memo on the Palm deleted.  Regardless of this special case, the behaviour
is at best undocumented, at worse a failure to check preconditions of switch
input.  Actually not a huge deal since, once known, it easy to avoid, but set to
high priority because, especially for a new user, it involves unintentional,
irrecoverable data loss of the last memo if that memo is newly entered on the
Palm and not backed up elsewhere.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Write several memos on Palm, note number and title of last memo
2.Run this command (note the period): memos -d .
3.Check Palm memo lists, note last one missing
	

Actual Results:  The last Palm memo on the list is deleteted even though no memo
number was specified.

Expected Results:  Either an error that no memo number was specificed
(preferred) or the usual behaviour given other options without any memo deletion.

Additional info:

Using Palm V, OS 3.1.1, 1430K free memory on Palm
Comment 1 Ivana Varekova 2006-07-31 09:24:19 EDT
Could you please try to reproduce this problem with the devel version of
pilot-link (pilot-link-0.11.8-16).
Comment 2 Bill Nottingham 2006-10-18 12:04:48 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.