Bug 75828 - umask of 077 causes wrong permissions on config files
Summary: umask of 077 causes wrong permissions on config files
Status: CLOSED DUPLICATE of bug 75091
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-13 11:41 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-13 11:41:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-13 11:41:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
This happens to me quite alot:

 When the umask is set to something "unexpected" like 077 as i have it 
 and the config tools are run under the user account (providing the root
password as needed) changes in the config files end up with the config files
having the access-permissions set to somthing like 600.
This of course disables stuff working. In fact i think it affects not only the
network config

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

Have the umask set to 077

1. start network config as std user
2. provide root password
3. change - let say the DNS domains to look for
4. save and exit setup	

Actual Results:  The config files (resolv.conf, hosts) and such have a file
permission of 600 which stops the network access from working for the standard user.
The content of the files is ok.

Expected Results:  the files should have the permissions as before

Additional info:

Comment 1 Harald Hoyer 2002-10-14 08:47:49 UTC

*** This bug has been marked as a duplicate of 75091 ***


Note You need to log in before you can comment on or make changes to this bug.