Bug 75838 - (UTF-8) vncserver does not respect selected keyboard layout
(UTF-8) vncserver does not respect selected keyboard layout
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: vnc (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-13 13:28 EDT by Ivo Sarak
Modified: 2013-04-30 19:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-13 09:38:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2002-10-13 13:28:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
vncserver does not use keyboard layout neither locally (before the run of
vncserver) or at runtime selected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set the keyboard Layout to ET either on console before the run of vncserver
or after inside the vncviewer session;
2. Fire up a konsole;
3. Type |uvd (first two of these are between 'P' and [ENTER], second two are a
line below after 'L'.)

Actual Results:  Take a look at konsole (IS@sarmax):
http://www.vendomar.ee/~ivo/vnc_et_layout.png

Expected Results:  konsole (IS@haskaa):
http://www.vendomar.ee/~ivo/vnc_et_layout.png

Additional info:
Comment 1 Ivo Sarak 2002-10-13 14:59:23 EDT
Strangely in case of already known bug
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75803), it will show these
characters:
http://www.vendomar.ee/~ivo/vncviewer_et_keymap_OK.png
Comment 2 Bill Nottingham 2006-08-07 15:07:25 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 3 Adam Tkac 2006-10-13 09:38:07 EDT
I'm going to close this bug because RHL doesn't have support. If the bug is in
latest vnc release, I'm ready to reopen this bug

Note You need to log in before you can comment on or make changes to this bug.