Bug 75841 - mc broken in UTF-8
mc broken in UTF-8
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mc (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
: Triaged
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-10-13 15:38 EDT by Ivo Sarak
Modified: 2015-01-07 19:01 EST (History)
5 users (show)

See Also:
Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-24 05:41:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2002-10-13 15:38:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Usage of Estonian characterset under mc is a mess.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run 'setup' and choose 'et' keymap;
2.Run a script 'echo '|uvd'> |uvd' (first two of these characters are between
'P' and [ENTER], second two are a line below after 'L'.);
3.Run mc;
4.Scroll to the end of this mc panel;
5.F3/F4 this file;
	

Actual Results:  Something like this:
http://www.vendomar.ee/~ivo/mc_et_mess.png
http://www.vendomar.ee/~ivo/mcedit_et_mess.png

Expected Results:  Estonian characters as they are no such things...

Additional info:

Typing of "dotted" characters under mc is not working, too - unexpected events
will follow or just some unrelated characters will appear.
Comment 1 Milan Kerslager 2002-10-17 15:08:14 EDT
Seems like MC dislike Unicode characters. I have LANG="cs_CZ.UTF-8" and national
characters inside panels (names of months) are garbled. MC badly format lines
with multibyte UTF character (ie probably thinks that multibyte chars are not
one but two or three separate chars).
Comment 2 Alec Voropay 2002-10-22 07:10:17 EDT
What is your locale ? Type `locale`.
Try `locale -a` and choose Estonian locale from list, then
$ export LANG={your locale}
before `mc`
Comment 3 Milan Kerslager 2002-10-22 07:53:08 EDT
I had czech locale (cs_CZ.UTF-8):

LANG=cs_CZ.UTF-8
LC_CTYPE="cs_CZ.UTF-8"
LC_NUMERIC="cs_CZ.UTF-8"
LC_TIME="cs_CZ.UTF-8"
LC_COLLATE="cs_CZ.UTF-8"
LC_MONETARY="cs_CZ.UTF-8"
LC_MESSAGES="cs_CZ.UTF-8"
LC_PAPER="cs_CZ.UTF-8"
LC_NAME="cs_CZ.UTF-8"
LC_ADDRESS="cs_CZ.UTF-8"
LC_TELEPHONE="cs_CZ.UTF-8"
LC_MEASUREMENT="cs_CZ.UTF-8"
LC_IDENTIFICATION="cs_CZ.UTF-8"
LC_ALL=

The bug is due to improper handling UTF-8 characters. Locales are fine but MC
should work properly in any cases.
Comment 4 Ivo Sarak 2002-10-22 14:03:40 EDT
I tried as proposed:

[root@sarmax root]# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
[root@sarmax roo
[root@sarmax root]# locale -a
C
en_AU
en_AU.utf8
en_BW
en_BW.utf8
en_CA
en_CA.utf8
en_DK
en_DK.utf8
en_GB
en_GB.iso885915
en_GB.utf8
en_HK
en_HK.utf8
en_IE
en_IE@euro
en_IE.utf8
en_IE.utf8@euro
en_IN
en_NZ
en_NZ.utf8
en_PH
en_PH.utf8
en_SG
en_SG.utf8
en_US
en_US.iso885915
en_US.utf8
en_ZA
en_ZA.utf8
en_ZW
en_ZW.utf8
et_EE
et_EE.utf8
POSIX
[root@sarmax root]# echo $LANG
en_US.UTF-8
[root@sarmax root]# export LANG=et_EE.utf8
[root@sarmax root]# mc

[root@sarmax root]# echo $LANG
et_EE.utf8
[root@sarmax root]# mkdir |uvd
[root@sarmax root]# mc

Result of it:

http://www.vendomar.ee/~ivo/mc_et_mess_export_lang.png

Results are the same as before.
Comment 5 Leonid Mamtchenkov 2002-11-08 10:31:56 EST
I think that mc is simply not Unicode aware.  It supports 8-bit input/output,
but it has no configuration for Unicode what-so-ever.
Comment 6 Ivo Sarak 2002-12-29 11:34:21 EST
With RedHat Public Beta Phoebe it is even worse:
http://www.vendomar.ee/~ivo/mc_et_mess2.png
Comment 7 Milan Kerslager 2003-01-18 14:20:09 EST
Confirmed that current Public Beta (and Raw Hide too) still has the problem.
Comment 8 Milan Kerslager 2003-05-24 05:41:46 EDT
Seems to be fixed in RH 9.

Note You need to log in before you can comment on or make changes to this bug.