Bug 75845 - RFE: right-click popup menu on panel authorization tool
Summary: RFE: right-click popup menu on panel authorization tool
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: usermode   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-13 22:17 UTC by Mike A. Harris
Modified: 2013-07-02 22:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 15:59:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2002-10-13 22:17:32 UTC
Not sure what the correct component is for our new GNOME panel applet
tool for remembering root authorization, and putting the set of keys
in the panel, so I chose "usermode" since it was the closest fit.

Please reassign to correct component if this isn't it.

Enhancement request:
I find myself intuitively right clicking on this panel applet when I
want to revoke root privs all the time, but right click doesn't do anything
currently.  A useful end-user friendly and likely simple to implement
enhancement would be making right-click on the keys popup a menu right
above the panel, like most Windows systray apps do, with the options
"Keep root priveledges" and "Revoke root priveledges" on it, or even
simply "Close" perhaps.

Just a simple useability enhancement.  It might make the popup window
dialog unnecessary perhaps too...

Comment 1 Jindrich Novy 2005-01-27 15:59:41 UTC
I added a pretty nice popup menu to pam-panel-icon which is invoked by
rightclicking the icon. This feature is introduced since
usermode-1.78-1. Enjoy! ;)


Note You need to log in before you can comment on or make changes to this bug.