Bug 758450 - askmethod installs fail when not using dhcp, never prompts for ip entry
askmethod installs fail when not using dhcp, never prompts for ip entry
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
ppc64 All
unspecified Severity urgent
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Betappc
  Show dependency treegraph
 
Reported: 2011-11-29 15:20 EST by IBM Bug Proxy
Modified: 2012-04-27 11:47 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 11:42:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
NFs-method-failed-logs.txt (21.43 KB, text/plain)
2011-11-29 15:20 EST, IBM Bug Proxy
no flags Details
nfsinstalllog.tgz contains anaconda.log syslog & program.log files (86.27 KB, application/x-compressed-tar)
2011-12-01 01:10 EST, IBM Bug Proxy
no flags Details
attaching anaconda.log as single plain text file (4.37 KB, text/plain)
2011-12-12 07:21 EST, Vratislav Podzimek
no flags Details
attaching program.log as single plain text file (596 bytes, text/plain)
2011-12-12 07:22 EST, Vratislav Podzimek
no flags Details
syslog.log as single plain text file (3.39 MB, text/plain)
2011-12-12 07:23 EST, Vratislav Podzimek
no flags Details
Proposed patch (3.02 KB, text/plain)
2011-12-22 12:51 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 76311 None None None Never

  None (edit)
Description IBM Bug Proxy 2011-11-29 15:20:21 EST
While installing Fedora16 PPC64 alpha using NFS method , it failed with error "The URL provided does not contain an installable tree ".

--- Steps to reproduce ---
1) download F16 alpha DVD
2) Boot from Virtual DVD 
3) While booting provide command line boot parameters as below boot prompt :
boot: linux askmethod serial vnc=1
4) Choose NFS type installation method and it will drop you to the error.

Please find details boot log & screen shot for this issue in attached file "NFs-method-failed-logs.txt".


1) My NFS exported directory contains all the mounted ISO repo files
[root@c57f1ju0202 ~]# ls /F16ALPHA/
etc     LiveOS    repodata                       RPM-GPG-KEY-fedora-16-secondary  RPM-GPG-KEY-fedora-ppc    RPM-GPG-KEY-fedora-s390x    RPM-GPG-KEY-fedora-x86_64
GPL     Packages  RPM-GPG-KEY-fedora             RPM-GPG-KEY-fedora-arm           RPM-GPG-KEY-fedora-ppc64  RPM-GPG-KEY-fedora-sparc    TRANS.TBL
images  ppc       RPM-GPG-KEY-fedora-16-primary  RPM-GPG-KEY-fedora-i386          RPM-GPG-KEY-fedora-s390   RPM-GPG-KEY-fedora-sparc64

[root@c57f1ju0202 ~]# mount | grep -i /F16ALPHA
/root/f16alphapub/Fedora-16-ppc64-DVD.iso on /F16ALPHA type iso9660 (rw,loop=/dev/loop0)

[root@c57f1ju0202 ~]# exportfs 
/F16ALPHA     	<world>

2) I booted with following parameters:
boot: linux serial debug askmethod  vnc=1

Right after providing NFS IP address and NFS installation directory path  , it took a longer time and then similar issue got reproduced. Note that it did not start the VNC because it is failing while trying access NFS path itself. Hence did not jump to any debug console, 

I had attached the the log file earlier named as "NFs-method-failed-logs.txt" for your reference.

With the boot prompt containing:
   linux serial askmethod asknetwork

I see the askmethod dialog.  I select NFS and enter the parameters.  Then, I see the network configuration dialog. I select DHCP.  I get a network error.  I retry.  After it fails again, I see the NFS dialog again, but not the network configuration dialog.
Comment 1 IBM Bug Proxy 2011-11-29 15:20:33 EST
Created attachment 538222 [details]
NFs-method-failed-logs.txt
Comment 2 Chris Lumens 2011-11-30 00:09:48 EST
Please attach /tmp/anaconda.log and /tmp/syslog to this bug report.  Thanks.
Comment 3 IBM Bug Proxy 2011-12-01 01:10:29 EST
------- Comment From maknayak@in.ibm.com 2011-12-01 01:03 EDT-------
(In reply to comment #31)
> Please attach /tmp/anaconda.log and /tmp/syslog to this bug report.  Thanks.

Hello Clumens,
I have attached a tar file named nfsinstalllog.tgz to the bugzilla,whihc contains  /tmp/anaconda.log , /tmp/syslog & /tmp/program.log files.

Thanks...
Manas
Comment 4 IBM Bug Proxy 2011-12-01 01:10:42 EST
Created attachment 538947 [details]
nfsinstalllog.tgz contains anaconda.log syslog & program.log files


------- Comment (attachment only) From maknayak@in.ibm.com 2011-12-01 01:00 EDT-------
Comment 5 Vratislav Podzimek 2011-12-12 07:21:18 EST
Created attachment 545689 [details]
attaching anaconda.log as single plain text file
Comment 6 Vratislav Podzimek 2011-12-12 07:22:07 EST
Created attachment 545690 [details]
attaching program.log as single plain text file
Comment 7 Vratislav Podzimek 2011-12-12 07:23:18 EST
Created attachment 545691 [details]
syslog.log as single plain text file
Comment 8 Vratislav Podzimek 2011-12-12 07:25:01 EST
Attach logs as single plain text files next time, please.
Comment 9 IBM Bug Proxy 2011-12-20 19:02:13 EST
------- Comment From hamzy@us.ibm.com 2011-12-20 18:52 EDT-------
On the second time around, configureTCPIP() seems to set skipForm to 1.

readNetConfig() should reset the selections to allow for re-entry.  See the following snipit:

int readNetConfig(char * device, iface_t * iface,
char * dhcpclass, int methodNum) {
...

i = wait_for_iface_activation(iface->device);
newtPopWindow();

if (i > 0) {
newtWinMessage(_("Network Error"), _("Retry"),
_("There was an error configuring your network "
"interface."));
/* Clear out selections to allow for re-entry */
iface->ipv4method = IPV4_UNUSED_METHOD;
iface->ipv6method = IPV6_UNUSED_METHOD;
return LOADER_ERROR;
}

return LOADER_OK;
}

Unfortunately, it is not clear which test is failing in readNetConfig().
Comment 10 IBM Bug Proxy 2011-12-22 12:51:14 EST
------- Comment From hamzy@us.ibm.com 2011-12-22 12:17 EDT-------
I see I was looking at the wrong place.  In loader/nfsinstall.c and the function promptForNfs(), there is a loop to detect if the NFS settings are correct.  You can back out of the loop, but you can't undo the network settings.
Comment 11 IBM Bug Proxy 2011-12-22 12:51:27 EST
Created attachment 549227 [details]
Proposed patch


------- Comment (attachment only) From hamzy@us.ibm.com 2011-12-22 12:19 EDT-------
Comment 12 Mark Hamzy 2012-01-16 17:31:19 EST
Hey Will,

Any progress on this?  Someone was asking if the fix was in.
Comment 13 Mark Hamzy 2012-01-16 17:33:06 EST
Proposed patch has been submitted to the mailing list:

https://www.redhat.com/archives/anaconda-devel-list/2011-December/msg00126.html
Comment 14 Mark Hamzy 2012-02-06 15:57:17 EST
Have you looked at this yet, Will?
Comment 15 IBM Bug Proxy 2012-02-27 13:02:09 EST
------- Comment From clnperez@us.ibm.com 2012-02-27 12:58 EDT-------
RH - Have you been able to look into this one?
Comment 16 Phil Knirsch 2012-04-27 11:42:51 EDT
Askmethod has been obsoleted in the latest version of anaconda and anaconda doesn't support any interactive actions in the first stage anymore.

Thanks & regards, Phil

Note You need to log in before you can comment on or make changes to this bug.