Bug 75849 - canon_pp driver is missing
canon_pp driver is missing
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sane-backends (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-13 20:14 EDT by Paul Gear
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.0.12-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-16 07:33:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Gear 2002-10-13 20:14:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
No driver for CanoScan parallel port scanners is shipped with Red Hat Linux 8.0.
 These are a very common range of consumer-oriented scanners.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install RHL8
2. Update locate database
3. locate canon_pp
	

Actual Results:  Find a man page, but no driver.

Expected Results:  Compiled backend ready to go.

Additional info:
Comment 1 Tim Waugh 2002-10-14 03:47:28 EDT
This back-end requires libieee1284, which is not included in Red Hat Linux.
Comment 2 Michael Wiktowy 2003-04-03 22:33:33 EST
Could libieee1284 be included in the Redhat distro so this driver could be
included? This inability to use my scanner has been frustrating. What are the
reasons for not including this base package?
Comment 3 Michael Wiktowy 2003-04-04 00:57:45 EST
I tried out a few things and got my CanoScan FB630P working from within Redhat 9
(and a few RPM packages from Mandrake).

For those of you interested (and that haven't bailed for another distro
already), here is what I did:

I made sure that my parallel port was being detected at bootup. You should see
something in "dmesg |less" about the parallel port. If not, try:
1) adding "alias paraport_lowlevel paraport_pc" into your /etc/modules.conf file.
2) turning off PnP in your BIOS for your parallel port.

I had problems at first and had to do at least one of those things for my port
to show up.

Uninstall the RedHat SANE packages with the command:
"rpm -e sane-backends-1.0.9-5 sane-frontends-1.0.9-2 xsane-0.89-3 xsane-gimp-0.89-3"

Downloaded and installed the following Mandrake packages:
gimp-libgimp-1.1.25-13mdk.i586.rpm
libieee1284_3-0.2.6-1.1mdk.i586.rpm
libsane1-1.0.9-3.1mdk.i586.rpm
sane-backends-1.0.9-3.1mdk.i586.rpm
sane-frontends-1.0.9-1.1mdk.i586.rpm
xsane-0.90-1.1mdk.i586.rpm
xsane-gimp-0.90-1.1mdk.i586.rpm

With optional OCR packages that interface with xsane:
gocr-0.37-2mdk.i586.rpm
gocr-gtk-0.37-2mdk.i586.rpm

Comment out (or delete) all but the "canon_pp" line in /etc/sane.d/dll.conf .
Otherwise xsane takes a long time finding your scanner as it works throught the
list. Leave the "net" line in as well if you want to have the scanner network
available via saned. I haven't experimented with that so I cannot confirm that
it works properly.

Add in the line "init_mode FB630P parport0" into /etc/sane.d/canon_pp.conf . The
FB630P is my scanner. The other options are FB620P or AUTO (which will try
both). parport0 since that was were my one and only parallel port ends up. If
you have multiple ports then this might be different.

If you don't want to run xsane as root (as is recommended by xsane on its
startup) then you have to change the permissions on /dev/parport0 to include the
users that you want to allow use of the parallel port. You could allow global
usage with the command "chmod o+rw /dev/parport0" or just add the users to group
"lp"

After banging my head each time a RedHat release would come out without the
canon_pp driver, I am happy that I have found success in some way and hope
others benefit from my collected advice.
Comment 4 Tim Waugh 2003-06-16 07:33:17 EDT
Fixed package will appear in rawhide shortly.

Note You need to log in before you can comment on or make changes to this bug.