Bug 758499 - after yum erase grub2 and rebuild of grub.conf, grub prompt received at boot
after yum erase grub2 and rebuild of grub.conf, grub prompt received at boot
Status: CLOSED DUPLICATE of bug 737731
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-29 17:30 EST by George R. Goffe
Modified: 2011-12-09 05:54 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-09 05:54:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description George R. Goffe 2011-11-29 17:30:53 EST
Description of problem:

I wanted to go back to using grub so I removed grub2 with "yum erase grub2" and had to rebuild the grub.conf file in /boot/grub/. Upon reboot I get a grub prompt. I'm trying to figure out what happened and what to do now.

Version-Release number of selected component (if applicable):

grub2 is at FC16 fully up to date.

How reproducible:

Probably always.

Steps to Reproduce:
1.see description of problem
2.
3.
  
Actual results:

see description of problem

Expected results:

A bootable system using grub (version 1)

Additional info:
Comment 1 Mads Kiilerich 2011-12-08 14:04:06 EST
grub is not supported on Fedora 16 and has been replaced with grub2, so you are on your own.

No matter what: There is no way this can be a grub2 problem - reassigning to grub.
Comment 2 George R. Goffe 2011-12-08 17:08:52 EST
Mads,

I'm confused then.

I did a FC14 upgrade to FC16 but had already installed grub2 before the upgrade via preupgrade.

Initially, both grub and grub2 existed in the FC16 system, HOWEVER, the grub binary was missing.

Perhaps there's a small glitch with the preupgrade? Perhaps the handling of the "grub" issue should be more verbose and do more checking? Some notice of migrating to grub2 or something. As it turns out, I DID have a upgrade failure during cleanup of glibc where the message mentioned grub or grub2. I DID save that log if you are interested in seeing it.

Thanks for your help.

George...
Comment 3 Mads Kiilerich 2011-12-09 05:54:21 EST
F14 preupgrade -> https://fedoraproject.org/wiki/Common_F16_bugs#Upgrade_from_Fedora_14_to_Fedora_16_with_preupgrade_leaves_bootloader_in_previous_configuration

*** This bug has been marked as a duplicate of bug 737731 ***

Note You need to log in before you can comment on or make changes to this bug.