Bug 75851 - dhcpd fails to ddns w/ Netgear print servers
dhcpd fails to ddns w/ Netgear print servers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-13 20:58 EDT by Trever Adams
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-03 17:05:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2002-10-13 20:58:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020916

Description of problem:
Well, I have a network with several linux and windows boxes on it.  I also have
a Netgear PS113 print server.  Ever dhcp client (of the router which is RedHat
8.0), works wonderfully with the ddns features of the new bind and dhcpd EXCEPT
the PS113.

Version-Release number of selected component (if applicable):
Version in RH Linux 8.0

How reproducible:
Always

Steps to Reproduce:
1. Set up a router
2. Make it DHCPD for the network with options ddns-update-style interim; ,
ignore client-updates; (the last just makes it obvious it is a bug in dhcpd).
3. Setup a network, put the PS113 on it.
4. Watch how dhcpd thinks its FQDN is just the hostname no "localdomain" or
other such thing appended even though the config tells it that it should.
	

Actual Results:  PS113 isn't updated to the dns properly.  Mine is currently
named PS344281.  My computer is aurora.  aurora.localdomain is auto-figured out
by dhcpd for the ddns.  It doesn't do this for PS344281.

Expected Results:  Everything should have the localdomain added and should
insert into DNS just fine.

Additional info:

Using ethereal it seems that the only thing that is really different (that would
matter) between linux, windows, and the PS113 is that the PS113 doesn't say tell
me what my domain name is.  Other than that, it overlaps w/ linux and windows
about the same they do with each other.

If the subnet has an option domain-name or ddns-domainname set it should always
be appended for ddns updates, not just for those that request the domain name.

The fix should be given back to ISC and a new release should be requested as
well as fixed rpms.

If someone wants to provide me with the appropriate way to capture aurora and
ps344281 doing DHCP interchange with the DHCPD, I will gladly do so.  I
currently have tcpdump and ethereal installed.  I would like it to be limited to
only dhcp.  I have other things going on I don't want in the capture.
Comment 1 Jason Vas Dias 2005-06-03 17:05:20 EDT
Sorry for the long delay in getting to this bug - it seems to 
have slipped through the cracks.
It should now be fixed with all recent versions of dhcp.

Comment 2 Trever Adams 2005-06-03 23:11:55 EDT
I believe it has been as I no longer use my hacked up scripts and the
print server seems to be just fine. Of course, this stupid print
server has tons of bugs (such as not releasing a ip before requesting
another) that aren't being fixed...

Thanks for checking up on this.

Note You need to log in before you can comment on or make changes to this bug.