Bug 758525 - [abrt] ibus-1.4.0-10.fc16: icon.py:38:__init__:GError: Icon 'gtk-missing-image' not present in theme
[abrt] ibus-1.4.0-10.fc16: icon.py:38:__init__:GError: Icon 'gtk-missing-imag...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:0388d8427aeddfcdd724339e644...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-29 19:11 EST by Simon A. Erat
Modified: 2011-12-07 02:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-07 02:50:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (2.81 KB, text/plain)
2011-11-29 19:11 EST, Simon A. Erat
no flags Details

  None (edit)
Description Simon A. Erat 2011-11-29 19:11:53 EST
libreport version: 2.0.7
abrt_version:   2.0.4.981
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
executable:     /usr/share/ibus/ui/gtk/main.py
kernel:         3.1.1-2.fc16.x86_64
reason:         icon.py:38:__init__:GError: Icon 'gtk-missing-image' not present in theme
time:           Sat 26 Nov 2011 04:58:11 AM CET
uid:            1000
username:       simon

smolt_data:     Text file, 2882 bytes

backtrace:
:icon.py:38:__init__:GError: Icon 'gtk-missing-image' not present in theme
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/ui/gtk/panel.py", line 683, in __status_icon_activate_cb
:    item.set_image(_icon.IconWidget("gtk-dialog-info", size[0]))
:  File "/usr/share/ibus/ui/gtk/icon.py", line 38, in __init__
:    pixbuf = theme.load_icon(gtk.STOCK_MISSING_IMAGE, size, 0)
:GError: Icon 'gtk-missing-image' not present in theme
:
:Local variables in innermost frame:
:theme: <gtk.IconTheme object at 0x2676d20 (GtkIconTheme at 0x24570b0)>
:icon: 'gtk-dialog-info'
:pixbuf: None
:self: <IconWidget object at 0x2676cd0 (GtkImage at 0x24f5420)>
:size: 16
Comment 1 Simon A. Erat 2011-11-29 19:11:56 EST
Created attachment 538322 [details]
File: smolt_data
Comment 2 fujiwara 2011-11-30 00:55:54 EST
Which desktop do you use?
ibus rpm has the dependency of gnome-icon-theme-legacy which has 'gtk-missing-image' icon.

Are you able to run the following script?

% cat a.py
import gtk

theme_name = gtk.settings_get_default().props.gtk_theme_name
icon_theme_name = gtk.settings_get_default().props.gtk_icon_theme_name
fallback_icon_theme = gtk.settings_get_default().props.gtk_fallback_icon_theme
print "theme_name:", theme_name
print "icon_theme_name:", icon_theme_name
print "fallback_icon_theme:", fallback_icon_theme

% python a.py
theme_name: Adwaita
icon_theme_name: gnome
fallback_icon_theme: gnome
Comment 3 Simon A. Erat 2011-11-30 12:14:27 EST
DE: LXDE

yum list gnome-icon-theme-legacy -->
Installed Packages
gnome-icon-theme-legacy.noarch                         3.2.1.2-1.fc16                          @updates
----------------------
Cant run the script, as i dont know how.
Tried to run it just like bash, which didnt work.

% cat a.py
import gtk

results in a "cross-mouse-cursor", dont know where i have to click it, result is empty.
---------------
Actualy i didnt even wanted to use ibus, but since i got an error, thought i report it.
Comment 4 fujiwara 2011-12-02 03:57:53 EST
(In reply to comment #3)
> Cant run the script, as i dont know how.
> Tried to run it just like bash, which didnt work.
> 
> % cat a.py
> import gtk

I mean to create the text file whose name is a.py and the context is:

import gtk

theme_name = gtk.settings_get_default().props.gtk_theme_name
icon_theme_name = gtk.settings_get_default().props.gtk_icon_theme_name
fallback_icon_theme = gtk.settings_get_default().props.gtk_fallback_icon_theme
print "theme_name:", theme_name
print "icon_theme_name:", icon_theme_name
print "fallback_icon_theme:", fallback_icon_theme


After you saved it, you could run the script with python command:

% python a.py

And I'd like to know the result after you executed 'python a.py'.
Comment 5 Simon A. Erat 2011-12-02 21:46:27 EST
-------------------------|
bin $ % python a.py
bash: fg: %: no such job
bin $ python a.py
theme_name: Industrial
icon_theme_name: oxygen
fallback_icon_theme: None
bin $ 
-------------------------|
Does this help?
Comment 6 Simon A. Erat 2011-12-02 21:58:35 EST
Ah yeah, almost most important.
During F16 alpha/beta, i never had this issue.
Since the release, i reinstalled lxde twice, at one time it happend once, but never since again.
Comment 7 fujiwara 2011-12-04 21:45:08 EST
(In reply to comment #6)
> Ah yeah, almost most important.
> During F16 alpha/beta, i never had this issue.
> Since the release, i reinstalled lxde twice, at one time it happend once, but
> never since again.

OK, I guess you didn't restart ibus when you update lxde.
Probably I'd close this bug if you don't see this now.
Comment 8 Simon A. Erat 2011-12-05 09:56:00 EST
Probably not. Didnt know one needs to restart ibus, as i never used it by specific usage.
From my point, yes it may be closed.

Note You need to log in before you can comment on or make changes to this bug.