Bug 75854 - ftp:// not recognised by prixovy
ftp:// not recognised by prixovy
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: privoxy (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-13 23:23 EDT by Mark Cooke
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-04 07:00:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Cooke 2002-10-13 23:23:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Using privoxy as a dropin replacement for squid+a redirector failed at our site
due to a number of browsers being configured with squid as an ftp proxy.

Squid can handle URL's of the form ftp://site/path/file, where privoxy fails,
attempting to access http://ftp://site/path/file, and failing the DNS resolution
of 'ftp'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Setup privoxy
2.Add the privoxy setup to the browser for http and ftp access
3.Attempt to follow an ftp:// link


Actual Results:  Privoxy failed to access the ftp:// URL with a DNS failure

Expected Results:  Privoxy could have complained that it cannot process ftp://
URL's (or gained support for the ftp:// method), possibly with a hint about
proxy settings.

Additional info:

Easy workaround by removing the indirection for ftp requests, but it's a pain
for novice users who are misled by a DNS related error message.
Comment 1 Hal Burgiss 2002-11-04 01:50:40 EST
There is an existing privoxy bug report/feature request for better error
messaging. The fact that ftp proxying does not work, is a FAQ:

5.5. I cannot connect to any FTP sites. Privoxy  seems to be blocking me.

Privoxy cannot act as a proxy for FTP traffic, so do not configure your browser
to use Privoxy as an FTP proxy. The same is true for any protocol other than
HTTP or HTTPS.

Most browsers understand FTP as well as HTTP. If you connect to a site, with a
URL like ftp://ftp.example.com, your browser is making an FTP connection, and
not a HTTP connection. So while your browser may speak FTP, Privoxy does not,
and cannot proxy such traffic.

=============

It is highly unlikely that ftp support will be added anytime soon, if ever.
Comment 2 Karsten Hopp 2002-11-04 08:06:07 EST
Hal:  
Many companies/users use squid to cache www-pages AND smaller FTP-downloads 
or just FTP directory information.  
If you chain squid with privoxy as mentioned in the user-manual  
(browser->squid->privoxy), you can't cache FTP-downloads anymore.  
I've tested the workaround for FTP/squid from the user-manual, unfortunately  
it doesn't work:  
  cache_peer 127.0.0.1 parent 8118 7 no-query  
  acl ftp proto FTP  
  always_direct allow ftp  
  never_direct allow all

Note You need to log in before you can comment on or make changes to this bug.