Bug 75856 - KDE desktop changes to GNOME desktop when I run nautilus from KDE
KDE desktop changes to GNOME desktop when I run nautilus from KDE
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 00:07 EDT by Need Real Name
Modified: 2015-01-07 19:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-17 07:08:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-14 00:07:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
The first time I had this happen, I was logged into KDE as a regular user, I had
su'd into root, and opened nautilus from the command line, and I saw what I
clearly recognized as the root desktop as it appears in GNOME.  Just to clarify
that, as a regular user, (as I experimented to see if I actually had root
priviledges) I not only had the root desktop from a completely different desktop
environment, but I also had full root priveledges.  But the problem still occurs
in whatever account I login under.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Log into KDE 
2.Open Nautilus from the command line (other ways may do it, I'm not sure, but
this way always does it)
3.You KDE desktop is now a GNOME desktop (The taskbar remains KDE)
	

Actual Results:  The KDE desktop (which is my default) becomes a Gnome desktop

Expected Results:  I expected Nautilus to open, and I expected my KDE desktop to
remain KDE, and not turn into a GNOME desktop

Additional info:

I am running Red Hat Linux 8.0, all official updates have been applied, AMD
Duron 650 mhz CPU, about 393 megabytes of RAM, and I installed EVERY package
(1400+, not sure of the exact number).  Oh yeah, I did a fresh install, not an
upgrade
Comment 1 Havoc Pennington 2002-10-14 00:33:56 EDT
nautilus should not be available in the GUI when running KDE, for this reason
among others. You aren't supposed to run nautilus in KDE.

The right fix for this requires coordination between kdesktop and nautilus.
Comment 2 Alexander Larsson 2003-01-17 05:32:39 EST
Hmmm. It seems the ugly kde hack workaround we had for this has been disabled.
Comment 3 Alexander Larsson 2003-01-17 06:24:00 EST
I'm re-enabling this in nautilus 2.1.91-7.
Comment 4 Alexander Larsson 2003-01-17 07:08:02 EST
It seems to work too.

Note You need to log in before you can comment on or make changes to this bug.