Bug 75861 - Sound doesn't work at all.
Summary: Sound doesn't work at all.
Status: CLOSED DUPLICATE of bug 54905
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: athlon Linux
high
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-14 05:47 UTC by Brad
Modified: 2013-07-03 02:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-14 08:11:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brad 2002-10-14 05:47:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
I have 2 Athlon PCs. One has an Epox 8KHA/+ motherboard and the other has an MSI
KT3Ultra2 motherboard. Both have an on-board VIA Technologies  VT8233 AC97 Audio
Controller and I cannot get sound from either one of them. Here are the entries
in /var/log/messages when I run sndconfig:

Oct 14 15:27:50 29 insmod:
/lib/modules/2.4.18-14/kernel/drivers/sound/via82cxxx_audio.o: init_module: No
such device
Oct 14 15:27:50 29 insmod: Hint: insmod errors can be caused by incorrect module
parameters, including invalid IO or IRQ parameters.       You may find more
information in syslog or the output from dmesg
Oct 14 15:27:50 29 insmod:
/lib/modules/2.4.18-14/kernel/drivers/sound/via82cxxx_audio.o: insmod
sound-slot-0 failed
Oct 14 15:27:50 29 modprobe: modprobe: Can't locate module sound-service-0-3


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run sndconfig
2. Hit OK
3. It finds the sound card:

A PCI sound card was found in your
system. The details are:

Model: VIA Technologies|VT8233
AC97 Audio Controller

4. Hit OK. It will now want to play a sound sample:

A sound sample will now be played to
determine if your sound card has been
correctly configured.

5. Hit OK.

6. It then displays:

The following error occurred running the modprobe program:

/lib/modules/2.4.18-14/kernel/drivers/sound/via82cxxx_audio.o:
init_module: No such device
/lib/modules/2.4.18-14/kernel/drivers/sound/via82cxxx_audio.o:
insmod
/lib/modules/2.4.18-14/kernel/drivers/sound/via82cxxx_audio.o:
failed
/lib/modules/2.4.18-14/kernel/drivers/sound/via82cxxx_audio.o:
insmod sound-slot-0 failed

7. Hit OK

It then launches you into a "Manual Configuration" screen which essentially
repeats the process again except you get to pick the driver.

Actual Results:  No sound and just errors on both the screen and in the messages
log file.

Expected Results:  The sound should have worked OK.

Additional info:

Comment 1 Jeff Garzik 2002-10-16 15:15:14 UTC

*** This bug has been marked as a duplicate of 54905 ***


Note You need to log in before you can comment on or make changes to this bug.