This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 75864 - kwin crashes when opens new window
kwin crashes when opens new window
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 02:52 EDT by Dusan Djordjevic
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-17 14:36:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dusan Djordjevic 2002-10-14 02:52:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
In situation when program tries to open new window which should get focus on it kwin crashes. It mostly happens with gtk programs (OpenOffice is almost unusable beacuse of this) but also in KDE programs. I use fresh installation of Red Hat 8.0 on IBM A31 laptop, Bluecurve theme and KDE environrment.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open kppp
2. Click Setup
3. Click on existing account and click edit
4. Click Add new phone number
	

Actual Results:  kwin crashes, so it has to be startted manually

Additional info:

here is backtrace log from kguard:
(no debugging symbols found)...[New Thread 8192 (LWP 1954)]
0x420ae169 in wait4 () from /lib/i686/libc.so.6
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40c20c63 in waitpid () from /lib/i686/libpthread.so.0
#3  0x4039a1c5 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  <signal handler called>
#5  0x41ac8d90 in KWinInternal::RedHatClient::addClientButtons(QString const&,
bool) () from /usr/lib/kde3/kwin_bluecurve.so
#6  0x41ac8b29 in KWinInternal::RedHatClient::RedHatClient(KWinInternal::Worksp
ace*, unsigned long, QWidget*, char const*) ()
   from /usr/lib/kde3/kwin_bluecurve.so
#7  0x41acbc9b in allocate () from /usr/lib/kde3/kwin_bluecurve.so
#8  0x400a81d6 in KWinInternal::PluginMgr::allocateClient(KWinInternal::Workspa
ce*, unsigned long, bool) () from /usr/lib/kwin.so
#9  0x4007b411 in KWinInternal::Workspace::clientFactory(unsigned long) ()
   from /usr/lib/kwin.so
#10 0x4007c3c8 in KWinInternal::Workspace::init() () from /usr/lib/kwin.so
#11 0x4007bf21 in KWinInternal::Workspace::Workspace(bool) ()
   from /usr/lib/kwin.so
#12 0x400a1dcc in Application::Application() () from /usr/lib/kwin.so
#13 0x400a236e in kdemain () from /usr/lib/kwin.so
#14 0x0804857b in main ()
#15 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6
Comment 1 Dusan Djordjevic 2002-10-14 03:32:14 EDT
It seems that problem is in Bluecurve window decoration. Since I changed it to Quartz window decoration, 
everything looks fine. I will continue testing...
Comment 2 Ngo Than 2002-12-17 14:36:57 EST
it's a bug in redhat-arwork. Please upgrade redhat-arwork-0.40-1 or newer, it
will fix this bug. You will find it in next rawhide release.

Note You need to log in before you can comment on or make changes to this bug.