Bug 758655 - connection-url should not be required when on Add XA Datasource operation
connection-url should not be required when on Add XA Datasource operation
Status: CLOSED WORKSFORME
Product: RHQ Project
Classification: Other
Component: Core UI, Operations (Show other bugs)
4.3
Unspecified Unspecified
medium Severity medium (vote)
: ---
: RHQ 4.3.0
Assigned To: Heiko W. Rupp
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2011-11-30 06:13 EST by Libor Zoubek
Modified: 2015-11-01 19:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-14 10:30:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2011-11-30 06:13:03 EST
Description of problem:

When creating new XA datasource on EAP6, UI forces you to insert Connection-url. But it does not make sense. 

1. Passing connection-url property XA DS creation command using eap6 cli results to failure, this means agent does not use this property, because creation XA DS using JON is successfull
2. Connection-url is not listed in configuration of any XA DS


Version-Release number of selected component (if applicable):
RHQ 4.3.0.SNAP Build Number: 4a6ec5f

How reproducible: always


Steps to Reproduce:
1. Inventory EAP6 (standalone)
2. create XA Datasource
3. assert connection-url property is not required
  
Actual results: connection-url property is required but not used anyway


Expected results:


Additional info:
Comment 1 Heiko W. Rupp 2012-01-30 08:01:38 EST
C-U. was required in earlier versions of AS7/EAP6 like the pool-name.
They have now been removed.

Also AS7-1209 is fixed and no more fake xa-properties need to be added.

master a8622b6e11a7
Comment 2 Heiko W. Rupp 2012-01-30 11:16:23 EST
master 4073cfff18630 contains additional fixes
Comment 3 Libor Zoubek 2012-02-03 09:48:35 EST
On Version: 4.3.0-SNAPSHOT Build Number: 58bf2d2 

Connection-url field is still mandatory in UI. New datasource that appears in EAP has connection-url undefined anyway 

/subsystem=datasources/xa-data-source=xa-ds:read-resource returns

"xa-datasource-properties" => {"connection-url" => undefined}
Comment 4 Heiko W. Rupp 2012-02-14 10:30:33 EST
connection-url stays, but is under the covers translated to a xa-property, so that it is more clear to the user that he needs to submit it and will not forget the xa-property.
More work on XA is done in Bug 708293

Note You need to log in before you can comment on or make changes to this bug.