Bug 75867 - kdeinit doesn't start after upgrading KDE to 3.0.3
kdeinit doesn't start after upgrading KDE to 3.0.3
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
8.0
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 04:39 EDT by Andrea Colanicchia
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-14 04:40:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Colanicchia 2002-10-14 04:39:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.0.1) Gecko/20020830

Description of problem:
After I upgraded my RH 7.2 to RH 8.0, kdeinit doesn't start.
I've already installed KDE 3.0.3 on my RH 7.3 from package available on KDE site
and prepared by RH, and it worked, but when I upgraded to RH 8.0, the
installation program has reinstalled the KDE 3.0.3 and, then, kdeinit didn't start.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install RH 7.2
2. Install KDE 3.0.3 on RH 7.2 with RPM on KDE site prepared by RH
3. Upgrade to RH 8.0 and reinstall KDE 3.0.3
4. Boot PC, log in and start KDE.
	

Actual Results:  kdeinit doesn't start.

Expected Results:  kdeinit MUST start :)

Additional info:

Kdeinit fails with a "relocation error" on FT_Get_Next_Char

relocation error: /usr/lib/libXft.so.2: undefined symbol:
FT_Set_Hint_Flags

Calling ldd on kdeinit (and on almost every other kde program
installed by RH8.0) i get the following results ldd -r
/usr/bin/kdeinit
         libDCOP.so.4 => /usr/lib/libDCOP.so.4 (0x40028000)
         libkparts.so.2 => /usr/lib/libkparts.so.2 (0x40059000)
         libkio.so.4 => /usr/lib/libkio.so.4 (0x40092000)
         libkdeui.so.4 => /usr/lib/libkdeui.so.4 (0x402ff000)
         libkdefx.so.4 => /usr/lib/libkdefx.so.4 (0x40517000)
         libXrender.so.1 => /usr/X11R6/lib/libXrender.so.1
         (0x4053e000) libkdesu.so.4 => /usr/lib/libkdesu.so.4
         (0x40543000) libkdecore.so.4 => /usr/lib/libkdecore.so.4
         (0x4055f000) libqt-mt.so.3 =>
         /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 (0x406b3000)
         libpng12.so.0 => /usr/lib/libpng12.so.0 (0x40ce1000)
         libz.so.1 => /usr/lib/libz.so.1 (0x40d04000) libX11.so.6
         => /usr/X11R6/lib/libX11.so.6 (0x40d12000) libSM.so.6 =>
         /usr/X11R6/lib/libSM.so.6 (0x40df0000) libICE.so.6 =>
         /usr/X11R6/lib/libICE.so.6 (0x40dfa000) libpthread.so.0
         => /lib/i686/libpthread.so.0 (0x40e11000) libdl.so.2 =>
         /lib/libdl.so.2 (0x40e41000) libXext.so.6 =>
         /usr/X11R6/lib/libXext.so.6 (0x40e44000) libresolv.so.2
         => /lib/libresolv.so.2 (0x40e52000) libstdc++.so.5 =>
         /usr/lib/libstdc++.so.5 (0x40e64000) libgcc_s.so.1 =>
         /lib/libgcc_s.so.1 (0x40f17000) libutil.so.1 =>
         /lib/libutil.so.1 (0x40f1f000) libm.so.6 =>
         /lib/i686/libm.so.6 (0x40f22000) libc.so.6 =>
         /lib/i686/libc.so.6 (0x42000000) libcups.so.2 =>
         /usr/lib/libcups.so.2 (0x40f44000) libmng.so.1 =>
         /usr/lib/libmng.so.1 (0x40f5f000) libjpeg.so.62 =>
         /usr/lib/libjpeg.so.62 (0x40fa3000) libGL.so.1 =>
         /usr/X11R6/lib/libGL.so.1 (0x40fc1000) libXmu.so.6 =>
         /usr/X11R6/lib/libXmu.so.6 (0x41034000) libXft.so.2 =>
         /usr/lib/libXft.so.2 (0x4104a000) libfontconfig.so.1 =>
         /usr/lib/libfontconfig.so.1 (0x4105c000)
 /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
         libssl.so.2 => /lib/libssl.so.2 (0x41082000)
         libcrypto.so.2 => /lib/libcrypto.so.2 (0x410b2000)
         libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x41186000)
         libfreetype.so.6 => /usr/X11R6/lib/libfreetype.so.6
         (0x411d8000) libexpat.so.0 => /usr/lib/libexpat.so.0
         (0x4120c000)
undefined symbol: FT_Get_Next_Char     
(/usr/lib/libfontconfig.so.1) undefined symbol: FT_Set_Hint_Flags
    (/usr/lib/libXft.so.2)

It seems it's a mismatch between kde app packages and Xft
delivered with RH8.0. It's strange that some people got KDE
working on RH8.0. I tried to update manually every package again,
and I downloaded and forced upgrading of Xft from RedHat site.
But I still get the error on kdeinit.
Gnome is ok for me, and it uses Xft as well, so it seems that Xft
rpm is ok, and the problem should be in kde packages.
Comment 1 Ngo Than 2002-10-15 17:32:32 EDT
It's not a bug in kdelibs. It seems that the update process did not work correct
on your system.

In your case here i recommend you should uninstall all qt/kde rpms frist and after
that you should install qt/kde from RHL 8.0.

Please make sure that all qt/kde rpms should be cleanly removed before you
install the new qt/kde rpms.

Comment 2 Andrea Colanicchia 2002-10-16 04:40:27 EDT
I've fixed this bug!!! 
The solution is create these symbolic links: 
 
lrwxrwxrwx    1 root     root           29 Oct 14 11:46 
/usr/X11R6/lib/libfreetype.so -> /usr/lib/libfreetype.so.6.3.1 
lrwxrwxrwx    1 root     root           29 Oct 14 11:44 
/usr/X11R6/lib/libfreetype.so.6 -> /usr/lib/libfreetype.so.6.3.1 
lrwxrwxrwx    1 root     root           29 Oct 14 11:46 
/usr/X11R6/lib/libfreetype.so.6.0 -> /usr/lib/libfreetype.so.6.3.1

Note You need to log in before you can comment on or make changes to this bug.