Bug 758676 - [abrt] ibus-1.4.0-11.fc16: __GI_raise: Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
[abrt] ibus-1.4.0-11.fc16: __GI_raise: Process /usr/bin/ibus-daemon was kille...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:91ac98d5877d534e67decd03dc9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-30 07:32 EST by rich
Modified: 2011-12-30 01:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-30 01:04:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (10.30 KB, text/plain)
2011-11-30 07:32 EST, rich
no flags Details
File: maps (8.63 KB, text/plain)
2011-11-30 07:33 EST, rich
no flags Details

  None (edit)
Description rich 2011-11-30 07:32:55 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/bin/ibus-daemon -r --xim
comment:        System was left idle for the night.  When I unlocked the screen in the morning, this error happened.
crash_function: __GI_raise
executable:     /usr/bin/ibus-daemon
kernel:         3.1.2-1.fc16.x86_64
pid:            3038
pwd:            /tmp
reason:         Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
time:           Wed 30 Nov 2011 06:38:53 AM EST
uid:            22899
username:       rrakich

backtrace:      Text file, 10549 bytes
maps:           Text file, 8838 bytes

build_ids:
:30af62b93e2ab7dbaf39c52e346cd52101b4b590
:e2e67b3ae2579e1667b73ad385f61552931024e9
:638db099ff5fb986d1a092629d1bb1dca5be4904
:3e2404bd469800afd61eda83d0292a2165ef0db0
:48d3cff26c916dff6cbcb5e67d5cf6d391f6ccca
:a7dfd8bf86205cbc61936a532e1110b635d91b8a
:022f1a6511ab7f46cc5b6f0df5852b50dfd46c85
:3ed9e61c2b7e707ce244816335776afa2ad0307d
:e3c88cb9ea428bd61f4064dbd53acae2d396a1ec
:b0eabf9093defbfdd0857ea3ed1a4563b743434e
:87461d97d0ba0bd94e4d74ff0879190b67b326c5
:650b733aecfb9c46bdfc023661f19244a278df04
:e5429e0905bedecc534b057783916ba43e06a66e
:ab59942678bcdecb23756804dcd0aac63ccc1669
:cd79409b99c12403d15f8db13d33f1f8dacb68cf
:0949b493f01e0553822be3bd14def9dbe79b804f
:e5d7ac2dfe435e205e491f7ce827563859fca4f4

dso_list:
:/lib64/libdl-2.14.90.so glibc-2.14.90-19.x86_64 (Fedora Project) 1322445580
:/lib64/libpthread-2.14.90.so glibc-2.14.90-19.x86_64 (Fedora Project) 1322445580
:/lib64/libgthread-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1320967294
:/usr/lib/locale/locale-archive glibc-common-2.14.90-19.x86_64 (Fedora Project) 1322445571
:/lib64/libglib-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1320967294
:/lib64/libgmodule-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1320967294
:/lib64/libc-2.14.90.so glibc-2.14.90-19.x86_64 (Fedora Project) 1322445580
:/lib64/librt-2.14.90.so glibc-2.14.90-19.x86_64 (Fedora Project) 1322445580
:/lib64/libresolv-2.14.90.so glibc-2.14.90-19.x86_64 (Fedora Project) 1322445580
:/usr/lib64/libffi.so.5.0.10 libffi-3.0.10-1.fc16.x86_64 (Fedora Project) 1320967291
:/lib64/libgio-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1320967294
:/lib64/libgobject-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1320967294
:/lib64/libselinux.so.1 libselinux-2.1.6-4.fc16.x86_64 (Fedora Project) 1320967252
:/lib64/libz.so.1.2.5 zlib-1.2.5-5.fc16.x86_64 (Fedora Project) 1321389920
:/lib64/ld-2.14.90.so glibc-2.14.90-19.x86_64 (Fedora Project) 1322445580
:/lib64/libnss_files-2.14.90.so glibc-2.14.90-19.x86_64 (Fedora Project) 1322445580

environ:
:SHELL=/bin/tcsh
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-Gus5GwwrT1,guid=a13e313bbfda4f228bc4d5e70000003e
:XDG_SESSION_COOKIE=4dee2b7be42ccbcf44d362ec00000015-1322486013.796824-1849561551
:XDG_RUNTIME_DIR=/run/user/rrakich
:DISPLAY=:0
:DESKTOP_SESSION=kde-plasma
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GDMSESSION=kde-plasma
:XDG_VTNR=1
:USERNAME=rrakich
:XDG_SESSION_ID=2
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-Gus5GwwrT1,guid=a13e313bbfda4f228bc4d5e70000003e
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-rrakich-dzLP2e/database
:USER=rrakich
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=2163
:SHLVL=1
:GDM_LANG=en_US.utf8
:PWD=/home/rrakich
:GNOME_KEYRING_CONTROL=/tmp/keyring-C6RLy1
:LANG=en_US.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=rrakich
:HOME=/home/rrakich
:LC_CTYPE=en_US.utf8
:GTK_IM_MODULE=ibus
:QT_IM_MODULE=ibus
:XMODIFIERS=@im=ibus

var_log_messages:
:Nov 30 06:38:53 rrakich-oc abrt[20532]: File '/usr/bin/ibus-daemon' seems to be deleted
:Nov 30 06:38:53 rrakich-oc abrt[20532]: Saved core dump of pid 3038 (/usr/bin/ibus-daemon) to /var/spool/abrt/ccpp-2011-11-30-06:38:53-3038 (54378496 bytes)
Comment 1 rich 2011-11-30 07:32:59 EST
Created attachment 538540 [details]
File: backtrace
Comment 2 rich 2011-11-30 07:33:04 EST
Created attachment 538541 [details]
File: maps
Comment 3 fujiwara 2011-12-01 02:52:46 EST
I cannot reproduce your problem.

From your backtrace, it seems gio vtable is failed.

Thread 1 (Thread 0x7f33f6fd87c0 (LWP 3038)):
#0  0x00000032a2236285 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux
#1  0x00000032a2237b9b in __GI_abort () at abort.c:91
#2  0x00000032a42683cd in g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x32ad302080 "call_in_idle_cb", message=0x1b48c20 "assertion failed: (vtable != NULL && vtable->method_call != NULL)") at gtestutils.c:1425
#3  0x00000032a42688f2 in g_assertion_message_expr (domain=0x32ad2e3721 "GLib-GIO", file=0x32ad300619 "gdbusconnection.c", line=4454, func=0x32ad302080 "call_in_idle_cb", expr=<optimized out>) at gtestutils.c:1436
#4  0x00000032ad2ae8f6 in call_in_idle_cb (user_data=0x7f33d805db60) at gdbusconnection.c:4454


Do you still see the same problem?

Note You need to log in before you can comment on or make changes to this bug.