Bug 75893 - xterm fonts missing characters (locale mismatch?)
xterm fonts missing characters (locale mismatch?)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 13:29 EDT by Kevin O'Connor
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-14 13:29:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin O'Connor 2002-10-14 13:29:37 EDT
Description of problem:
The default font of an xterm window can't render many of the characters that are
frequently found in program like nroff, mutt, etc.  This appears to be related
to the change to LANG=en_US.UTF-8.  However, reverting back to LANG=en_US still
leads to unsatisfactory results (and differs from RedHat-7.3 behavior).  In the
end, I was able to resolve the issue by forcing iso10646-1 fonts.  If this is
the "true solution" then I suggest /usr/X11R6/lib/X11/fonts/misc/fonts.alias be
changed so that the common aliases (such as "fixed", "6x13", "10x20", etc.) use
the iso10646-1 fonts.

How reproducible:
Always

Steps to Reproduce:
1.Open an xterm and a gnome-terminal side-by-side
2.run "man tcsh" (or whatever) in both windows

Notice how hyphens and quotes are missing in the xterm window
Comment 1 Mike A. Harris 2002-11-02 05:32:33 EST
This is not a bug in xterm.  mutt, pine and other programs are simply
clueless towards unicode.

There are numerous open, and closed bugs filed against xterm, xchat,
man, pine, mutt, and other programs, and also various manpages - all of
which are NOTABUG also.  Feel free to query bugzilla for UTF-8 and
"unicode" for much more details.

Also note, that if this was a legitimate bug in xterm (which it isn't),
Red Hat does not at all support xterm.  Any real bugs in xterm are to
be reported by the bug reporter directly to XFree86.org, or to the
official xterm maintainer (Thomas Dickey I believe).  xterm is
included in Red Hat Linux merely as convenience for users used to it,
or who prefer it, but it is provided unsupported as-is.  If it ever
becomes unsupported upstream and buggy, it will be removed from the
distribution completely.

Closing bug NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.