Bug 75894 - Installer crashed during Upgrade of a system with LVM partition
Installer crashed during Upgrade of a system with LVM partition
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 14:19 EDT by Philippe Rigault
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-01 14:53:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Rigault 2002-10-14 14:19:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
Installer crashed during 'Upgrade Existing System'
System information:
  i686 laptop (Dell Inspiron 8000) with two hard disks
  hda has ext3 partitions
  hdc has one large LVM partition (created with LVM under RedHat 7.3)

The install fails when trying to detect existing partitions (detailed trace
included below)
If I remove physically the hard disk that has the LVM partition (hdc), the
install works successfully.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create an LVM partition on a hard disk in a RedHat 7.3 system. (I have ond
hard disk setup with one large LVM partition for the whole disk)
2.Reboot the machine with RedHat 8.0 install CD 
3.Select 'Upgrade Existing System' duering the install. The install crashes upon
detection of existing partitions.
	

Actual Results:  Install crashed, unable to upgrade system.

Expected Results:  Install should recognize LVM partitions, or at least ignore
partitions that it cannot deal with instead of crash.

Additional info:

Trace of the crash below (copied from the screen):

Traceback (most recent call last)
 File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
   set.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
   set.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
   rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/upgrade.py", line 37, in findRootParts
   parts = findExistingRoots(intf, id, chroot)
 File "/usr/lib/anaconda/upgrade.py", line 49, in findExistingRoots
   rootparts = diskset.findExistingRootPartitions(intf, chroot)
File "/usr/lib/anaconda/lvm.py", line 38, in vgscan
   raise SystemError, "vgscan failed"
SystemError: vgscan failed
Comment 1 Jeremy Katz 2002-10-14 14:47:51 EDT
If you go over to tty2 and run vgscan by hand, what sort of error message do you
get?
Comment 2 Philippe Rigault 2002-10-14 15:19:53 EDT
-/bin/sh-2.05b# vgscan
vgscan -- reading all physical volumes (this may take a while...)
Segmentation fault
Comment 3 Michael Fulbright 2002-10-24 15:00:50 EDT
But if you run vgscan when you reboot into 7.3 it has no problems?
Comment 4 Bill Hilf 2002-10-24 21:44:44 EDT
I'm having a similar problem.  Two HDDs in an i686 IBM ThinkPad 600X.  hd0 is
HPFS/NTFS (W2K), hd1 is Linux Native (RH 7.3).  RH8 anaconda install crashes
when trying to 'upgrade exisitng' or 'install workstation'.  Don't have a
traceback, the 'save to disk' failed to write to my floppy.  But this is always
reproducable.
Comment 5 Michael Fulbright 2002-11-01 12:55:45 EST
Has the original bug reporter had a chance to try running vgscan on their 7.3
system?
Comment 6 Philippe Rigault 2002-11-01 14:53:46 EST
>Has the original bug reporter had a chance to try running vgscan on their 7.3
system?
No, because this machine is now upgraded to 8.0 (physically unplugging the hard
disk containing LVM partition allowed the install to go through) and I reduilt
partitions on that disk too,so I won't be able to test either the LVM partition
or 7.3 on the same setup. Sorry.
Comment 7 Michael Fulbright 2002-11-06 12:05:07 EST
No problem, good to here you have it working!

Note You need to log in before you can comment on or make changes to this bug.