Bug 75895 - Gconfd continues to run after logging out -- causes umount to fail
Gconfd continues to run after logging out -- causes umount to fail
Status: CLOSED DUPLICATE of bug 67605
Product: Red Hat Linux
Classification: Retired
Component: GConf2 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 14:20 EDT by W. Michael Petullo
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2002-10-14 14:20:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
The gconfd-2 daemon is run by many GNOME applications to manage configurations.
 Gconfd-2 remains running for some time after the application which used it
quits.  This allows other applications to use gconfd-2 without having to start
and stop the daemon too much.  This is a good idea.

The problem comes when a system tries to unmount a user's home directory when
the user logs out.  For example, pam_mount unmounts an encrypted home directory
then I log out of my system.

Gconfd-2 continues to run even when a user logs out.  This causes the unmounting
of the user's home directory to fail because gconfd-2 keeps the following files
open:

/home/user/.gconfd/lock/<random string>
/home/user/.gconf/%gconf-xml-backend.lock/<random string>
/home/user/.gconfd/saved_state

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Log in to system as mike
<pam_mount mounts /home/mike automatically>
2.  Run any program that causes gconfd-2 to execute (ie: galeon)
3.  Log out
<pam_mount fails to unmount /home/mike>
4.  Try to unmount /home/mike by hand.
	

Actual Results:  It is impossible to unmount /home/mike until:

gconfd-2 releases /home/user/.gconfd/saved_state

and later releases /home/user/.gconfd/lock/<random string> and
/home/user/.gconf/%gconf-xml-backend.lock/<random string>

Expected Results:  Gconfd-2 should continue to exibit "stay up for a while after
using application exits" behavior but should exit *immediately* when mike logs
out (before PAM calls pam_close_session).  This should release all of the open
files in /home/mike and it should immediately be possible to unmount /home/mike.

Additional info:

Pam_mount is a PAM module that mounts/unounts volumes (encrypted, samba, Novell,
etc.) at login/logout time.
Comment 1 Josiah Royse 2002-12-02 14:57:19 EST
It is documented on the http://www.gnome.org/projects/gconf/ website.

To get the gconf lock file out of the NFS mounted home directory and into the
/tmp directory I added this to the /etc/skel/.bashrc or ~/.bashrc file:

# Added for local /tmp/ file locking for gnome
export GCONF_LOCAL_LOCKS=1

This is aparently only patched on RH8.0 Gconf2...?
Comment 2 Eric Bourque 2002-12-02 15:08:16 EST
Since the above patch is listed as an experimental patch, my solution was to add
to /etc/X11/gdm/PostSession/Default:

# fixes for gconf not stopping
/usr/bin/killall /usr/libexec/gconfd-2
/usr/bin/killall oafd

Now when I log out of X, I can shutdown properly without waiting forever.
Comment 3 Havoc Pennington 2002-12-19 18:57:27 EST

*** This bug has been marked as a duplicate of 67605 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:49:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.