Bug 75899 - .bash_profile does not source my keychain files
.bash_profile does not source my keychain files
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 14:55 EDT by Nick Urbanik
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-09 11:56:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Urbanik 2002-10-14 14:55:05 EDT
Description of Problem: .bash_profile does not source my keychain files


Version-Release number of selected component (if applicable): bash-2.05b-5


How Reproducible: Every time on this machine


Steps to Reproduce:
1. Install keychain 2.0.2 (or  number of previous versions, each set up correctly)
2. Add the two lines to ~/.bash_profile required for normal keychain operation
3. Log in, enter passphrase into gnome-ssh-askpass
4. Open a terminal (xterm or gnome-terminal)
5. Type ssh-add -l; see "The agent has no identities."
6. source .bash_profile or source ~/.keychain/${HOSTNAME}-sh, then ssh-add -l
lists all my keys, and everything works, but only for that terminal.

Actual Results: See "The agent has no identities." unless source .bash_profile
or ~/.keychain/${HOSTNAME}-sh


Expected Results: See output listing my keys when type ssh-add -l, and expect
ssh to work using public key authentication.


Additional Information: It always worked for me with previous versions of Red
Hat Linux.

I am willing to spend some effort in tracking this down if you can offer any
suggestions.  I will try in the College soon with many fresh RH 8.0 installations.

$ grep keychain ~/.bash_profile
/usr/bin/keychain ~/.ssh/id_rsa ~/.ssh/id_dsa ~/.ssh/identity
. ~/.keychain/${HOSTNAME}-sh
$ echo $SHELL
/bin/bash
Comment 1 Tim Waugh 2002-10-14 16:12:50 EDT
Followed your steps to reproduce: it works for me.  You'll need to find a 
smaller example that doesn't work for you. 
 
Was this an installation or an upgrade?
Comment 2 Nick Urbanik 2002-10-15 05:03:09 EDT
It was an upgrade (using rpmfind on a system running on LVM on RAID).

I established that it worked for a fresh install.  However, I don't understand
what is not right.  I'd better do some more trouble shooting after more sleep.
Comment 3 James Hunt 2002-12-05 11:00:24 EST
I have the same problem. I'm running RH8.0 - clean install. It worked fine under
7.3.
Comment 4 James Hunt 2002-12-06 03:44:09 EST
Even though I did a fresh install of RH8, I then re-instated my configuration
files in $HOME. I don't know what changed in /etc between 7.3 and 8.0, but the
fix is to run your chosen terminal emulator with the "-ls" option to get a login
shell. For example,

    xterm -ls
    aterm -ls


Note You need to log in before you can comment on or make changes to this bug.