Bug 759009 - Attributes with language subtypes cannot be synced to AD
Summary: Attributes with language subtypes cannot be synced to AD
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: 7.3
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks: 389_1.2.10
TreeView+ depends on / blocked
 
Reported: 2011-12-01 08:52 UTC by Juan
Modified: 2016-01-05 01:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-05 01:32:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Juan 2011-12-01 08:52:46 UTC
Description of problem:

In our directory, we have some users with attributes like cn;lang-en,
sn;lang-en, with the same value than cn or sn, but without tildes (á,
è) or "ñ". When I try to synchronize these users with Active
Directory, I get this error:

[30/Nov/2011:11:58:32 +0100] - Windows sync entry: Created new remote entry:
 dn:: XXXXXXX
objectClass: top
objectClass: person
objectClass: organizationalperson
objectClass: user
userprincipalname: XXXXXXX@pruebas.local
st: XXXXXXX
postalCode: XXXXXXX
postalAddress:: XXXXXXX
streetAddress:: XXXXXXX
facsimileTelephoneNumber: XXXXXXX
telephoneNumber: XXXXXXX
mail: XXXXXXX
o: XXXXXXX
l: XXXXXXX
ou: XXXXXXX
givenName: XXXXXXX
sn:: XXXXXXX
cn:: XXXXXXX
sAMAccountName: XXXXXXX
accountExpires: 0
codePage: 0
sn;lang-en: XXXXXXX

[30/Nov/2011:11:58:32 +0100] - Attempting to add entry
cn=XXXXXXX,ou=LDAPPeople,dc=pruebas,dc=local to AD for local entry
uid=XXXXXXX,ou=People,o=XXXXXXX,dc=XXXXXXX,dc=XXXXXXX
[30/Nov/2011:11:58:32 +0100] NSMMReplicationPlugin - agmt="cn=ll"
(XXXXXXX:636): Received result code 16 (00000057: LdapErr:
DSID-0C090B38, comment: Error in attribute conversion operation, data
0, vece) for add operation

If I remove the attribute "sn;lang-en", the sync works fine.

Attributes with language subtypes should not be synced with Active Directory, as they are not supported.


Version-Release number of selected component (if applicable): Tested in 1.2.5


How reproducible/Steps to Reproduce/Actual results/Expected results:

1. Modify/Add a user an attribute with subtype language
2. Initiate a full resynchronization
3. The synchronizations fails due to the previous errors

Comment 1 Martin Kosek 2012-01-04 13:12:54 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/11

Comment 2 Rich Megginson 2012-01-10 18:02:21 UTC
marking as screened because it has been cloned upstream

Comment 5 Noriko Hosoi 2016-01-05 01:32:16 UTC
Closing this bug with NOTABUG.

For more details, see also:
https://fedorahosted.org/389/ticket/11#comment:11


Note You need to log in before you can comment on or make changes to this bug.