Bug 759014 - IMSM: Incremental assembly of degraded arrays using wrong index
IMSM: Incremental assembly of degraded arrays using wrong index
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jes Sorensen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 759015 759016
  Show dependency treegraph
 
Reported: 2011-12-01 04:08 EST by Jes Sorensen
Modified: 2012-05-04 12:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 759015 759016 (view as bug list)
Environment:
Last Closed: 2012-05-04 12:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jes Sorensen 2011-12-01 04:08:52 EST
Description of problem:
Incremental in some cases prematurely assembles degraded arrays due to
wrong index used in code which counts missing disks.

http://marc.info/?l=linux-raid&m=132206766827484&w=2
Comment 1 Jes Sorensen 2012-01-05 08:38:21 EST
Fixed in mdadm-3.2.3

Note You need to log in before you can comment on or make changes to this bug.