Bug 75904 - 80 character lines stick together when selected
80 character lines stick together when selected
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
: 77623 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 15:33 EDT by Pete Zaitcev
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.13.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 17:20:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2002-10-14 15:33:49 EDT
Description of Problem:

When 80 character lines are output on the screen and selected,
they get glued together.

Version-Release number of selected component (if applicable):

gnome-terminal-2.0.1-5

How Reproducible:

Always

Steps to Reproduce:
1. Create a file with two lines exactly 80 characters in size, name it 'foo'.
2. Open an editor
3. cat foo
4. Select those two line as printed by cat, and paste into the editor
   with middle button
5. Result is two lines stuck together

Actual Results:

One line pasted

Expected Results:

Two lines pasted

Additional Information:
	
This bug is NOT a regression from RH7.3, it is just a maddening bullshit
which Zuccini and Miggie refuse to fix for years. I thought since we
have a new gnome-terminal we might want to fix that.

xterm works correctly in this regard.
Comment 1 Miloslav Trmac 2002-10-15 10:02:16 EDT
Please, fix it ONLY if selecting a line longer than 80 characters
(which wraps without embedded '\n') will not make a selection split into
two lines.
Comment 2 Ray Strode [halfline] 2004-11-09 14:09:56 EST
This bug still seems to be present in the latest vte.
Comment 3 Pete Zaitcev 2004-11-09 14:30:32 EST
Verified still broken in vte-0.11.11-6 (FC3).
It looks I was agitated when I filed this two years ago, I'm sorry.
Meanwhile, I got into a habit of opening all files in gvim and
selecting there, as a workaround.
Comment 4 Ray Strode [halfline] 2004-11-10 15:39:53 EST
*** Bug 77623 has been marked as a duplicate of this bug. ***
Comment 5 Behdad Esfahbod 2006-07-27 17:20:03 EDT
Fixed upstream.

Note You need to log in before you can comment on or make changes to this bug.