Bug 759115 - RFE: headpin ping should provide result for thumbslug
RFE: headpin ping should provide result for thumbslug
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
medium Severity medium
: rc
: 1.X
Assigned To: Adam Price
sthirugn@redhat.com
: FutureFeature, Triaged
Depends On: 871586
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2011-12-01 08:04 EST by Eric Sammons
Modified: 2013-10-01 06:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 06:47:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2011-12-01 08:04:04 EST
Description of problem:
The headpin cli ping command currently provides results for critical components; candlepin and candlepin_auth.  In katello pulp pulp_auth are also provided, headpin as a on premise subscription management tool requires a functional thumbslug, therefore ping should return a result for thumbslug.

Version-Release number of selected component (if applicable):
katello-cli-headpin-0.1.12-1.el6.noarch

Steps to Reproduce:
1. headpin -u admin -p admin ping
  
Actual results:
 Status   Service          Result   Duration   Message                      
------------------------------------------------------------------------------------------
 fail                                                                       
          candlepin        ok       16ms                                    
          candlepin_auth   ok       14ms                                    
          pulp             fail                404 Resource Not Found       
          pulp_auth        fail                uninitialized constant Pulp  


Expected results:
 Status   Service          Result   Duration   Message                      
------------------------------------------------------------------------------------------
 ok                                                                       
          candlepin        ok       16ms                                    
          candlepin_auth   ok       14ms                                    
          thumbslug        ok       XXms


Additional info:
Currently pulp is erroneously reported on see bz 754840.
Comment 3 Adam Price 2013-01-16 11:57:16 EST
https://github.com/Katello/katello/pull/1384
Comment 5 sthirugn@redhat.com 2013-02-11 14:31:15 EST
Note for Retest:
Together with katello/headpin ping, please also test the SAM GUI -> About page under the System Status section for the presence of Thumbslug information.
Comment 6 Bryan Kearney 2013-06-06 16:50:26 EDT
Moving all POST / MODIFIED bugs to ON_QA due to the new builds.
Comment 7 sthirugn@redhat.com 2013-07-05 15:15:21 EDT
Verified in latest headpin nightly.

# headping -u admin -p admin ping
--------------------------------------------------------------------------------
                                 Katello Status

Status Service        Result Duration Message 
--------------------------------------------------------------------------------
ok     
candlepin      ok     47ms     
candlepin_auth ok     51ms     
elasticsearch  ok     34ms     
katello_jobs   ok     73ms     
thumbslug      ok     65ms 

Additionally SAM GUI -> About page -> System Status section also shows the Thumbslug information.

Version Tested:
* candlepin-0.8.16-1.el6.noarch
* candlepin-cert-consumer-ibm-x3655-03.ovirt.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-tomcat6-0.8.16-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.107.43fee0b.el6.noarch
* katello-cli-common-1.4.2-1.git.107.43fee0b.el6.noarch
* katello-common-1.4.2-1.git.812.a3a58dc.el6.noarch
* katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.812.a3a58dc.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.812.a3a58dc.el6.noarch
* katello-headpin-1.4.2-1.git.812.a3a58dc.el6.noarch
* katello-headpin-all-1.4.2-1.git.812.a3a58dc.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
* thumbslug-0.0.27-1.el6.noarch
* thumbslug-selinux-0.0.27-1.el6.noarch
Comment 9 errata-xmlrpc 2013-10-01 06:47:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.