Bug 759132 - Fix regression in default $status value in case of lists/pipelines
Fix regression in default $status value in case of lists/pipelines
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tcsh617 (Show other bugs)
5.8
All Linux
high Severity high
: rc
: ---
Assigned To: Vojtech Vitek
Branislav Náter
: Patch, Regression
: 735902 (view as bug list)
Depends On: 638955
Blocks: 798457 807971 784510
  Show dependency treegraph
 
Reported: 2011-12-01 08:50 EST by Vojtech Vitek
Modified: 2015-03-04 18:57 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 638955
: 784510 (view as bug list)
Environment:
Last Closed: 2013-01-08 02:26:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 40784 None None None Never

  None (edit)
Comment 1 Vojtech Vitek 2011-12-01 09:02:02 EST
Upstream bug: http://bugs.gw.com/view.php?id=155
Comment 2 Vojtech Vitek 2012-01-25 03:29:40 EST
*** Bug 735902 has been marked as a duplicate of this bug. ***
Comment 3 Vojtech Vitek 2012-03-24 21:51:57 EDT
We are going to revert the tcsh exit value behaviour to the CSH default (as it used to work in tcsh for many years/decades). There will be $tcsh_posix_status variable available to opt-in the POSIX-like behaviour (as in bash, ksh, etc.).

$ false | true
$ echo $?
1
$ set tcsh_posix_status
$ false | true
$ echo $?
0
Comment 9 errata-xmlrpc 2013-01-08 02:26:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0052.html

Note You need to log in before you can comment on or make changes to this bug.