Bug 75914 - screen UTF-8 encoding option missing (Unknown option -U)
screen UTF-8 encoding option missing (Unknown option -U)
Status: CLOSED DUPLICATE of bug 78392
Product: Red Hat Linux
Classification: Retired
Component: screen (Show other bugs)
8.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 18:38 EDT by Need Real Name
Modified: 2007-03-26 23:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-15 11:54:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-14 18:38:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
In GNU screen 3.9.11, the following option is present:

-U            Tell screen to use UTF-8 encoding.

However, in Red Hat 8.0, this option is removed.

Why?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Invoke screen with the -U option.


	

Actual Results:  
  Error: Unknown option -U


Expected Results:  I want to tell screen that my terminal sends/receives UTF-8
codes.

If the behaviour is correct could you recommend another method 
to connect to a legacy Red Hat system (not running UTF-8) from 
a Red Hat 8.0 UTF-8 system?  (Not vice versa, I did try that.)

Additional info:
Comment 1 Lon Hohberger 2002-10-15 11:54:14 EDT
Screen's UTF-8 support is buggy (as of 3.9.11), so we don't compile it with
UTF-8 support.

I'm not sure what exactly you're trying to accomplish; please clarify for me. 
It could be that the answer to your problem is simply to connect via ssh to the
remote host (the legacy machine) and running screen on it through your ssh
connection, rather than using screen locally to multiplex several ssh
connections to the remote host.

(Will close as 'WONTFIX' pending your response.)
Comment 2 Lon Hohberger 2002-12-05 16:07:06 EST
I am evaluating a new version of screen to see if the reasons we removed UTF-8
have been resolved.

See bug #78392

*** This bug has been marked as a duplicate of 78392 ***

Note You need to log in before you can comment on or make changes to this bug.