Bug 75915 - Probelms with cut and paste non-English text
Probelms with cut and paste non-English text
Product: Red Hat Linux
Classification: Retired
Component: qt (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2002-10-14 19:05 EDT by Eugene Kanter
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-28 12:45:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2002-10-14 19:05:37 EDT
Description of Problem:

Pasting non-English text from xterm or gnome to KDE applications doest now work

How Reproducible:


Steps to Reproduce:
1. Use default Russian install or just start xterm or gnome-terminal in
ru_RU.KOI8-R (or other similar) locale.
2. Install Russian keyboard by
setxkbmap -option grp_led:scroll -option grp:shift_toggle "ru"
3. Switch to Russian keyboard by pressing two shifts simultaneously and type
some words in xterm.
4. Highlight the typed words with the mouse pointer.
5. Start KDE editor kate. Make sure it accepts Russian text from keyboard,
otherwise configure KDE properly.
6. With the text from item 4 still in X buffer press middle mouse button in kate.

Actual Results:

Instead of Russian there is accented Latin-1 text.

Expected Results:

Russian text gets properly pasted into kate.
Comment 1 Eugene Kanter 2002-10-23 10:33:43 EDT
From: qt-bugs trolltech.com
Subject: [Issue N9274] copy and paste problems
Hello Eugene,
This is a known issue and has been fixed in Qt 3.0.6 and above.
Thank you,
Trenton Schulz
Trolltech AS, Waldemar Thranes gt. 98, NO-0175 Oslo, Norway
Comment 2 Eugene Kanter 2002-10-24 09:55:11 EDT
> Would it be possible to provide a patch (or at least point to changed
> file) relative to 3.0.4?

I'm sorry, but it is a fairly large fix, and since 3.0.5 and 3.0.6 have
been released, we don't typically give out patches for older versions.

I guessing though that the affected file would probably be

Hope this helps,

Trenton Schulz
Trolltech AS, Waldemar Thranes gt. 98, NO-0175 Oslo, Norway
Comment 3 Eugene Kanter 2002-10-28 12:45:08 EST
Tried qt-3.0.6. Success.
Comment 4 Ngo Than 2002-11-05 09:13:05 EST
It's fixed in 3.0.6. You will find it in next rawhide release.

Note You need to log in before you can comment on or make changes to this bug.