Bug 75920 - Copying files from file:/... to sftp:/ fails
Copying files from file:/... to sftp:/ fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 19:49 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 06:54:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-14 19:49:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; da-DK; rv:1.1) Gecko/20020826

Description of problem:
Copying a file from local harddisk to an sftp destination with konqueror fails.
When the entire file has been copied, the system is not able to rename the file
at destination, tells that the file cannot be copied, and asks about cancel or
skip. But if you choose skip, you just have to rename the file from
filename.part to filename to make it work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Ensure you can ssh to another Red Hat Linux 8.0 server using IP address.
2. Open two konqueror windows.
3. Make one of the konqueror windows point to sftp://lars@ip-address/home/test,
and enter the username for the user lars at the other pc, when it asks you to do so.
4. Drag and drop a file named FILENAME from the local konqueror to the sftp:/
konqueror window.
	

Actual Results:  A file is created at the destination named FILENAME.part, and
konqueror then asks if you want to cancel or skip the file, because it couldn't
be copied.

Expected Results:  I would except the file to be copied and named FILENAME.

Additional info:

If I press "Skip file", and then rename the FILENAME.part file to FILENAME at
the destination, the file has been copied perfectly. It seems that it's the
renaming that fails. All filenames and directory names in this only contain
standard ascii characters (a-z, A-Z).
Comment 1 Ngo Than 2004-07-28 06:54:04 EDT
it's not reproduceable in current release (fc1/fc2)

Note You need to log in before you can comment on or make changes to this bug.