Bug 759206 - [abrt] rygel-0.12.5-1.fc16: signal_emit_unlocked_R: Process /usr/bin/rygel was killed by signal 11 (SIGSEGV)
Summary: [abrt] rygel-0.12.5-1.fc16: signal_emit_unlocked_R: Process /usr/bin/rygel wa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rygel
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ebfe6eba323d635471974153d52...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-01 16:51 UTC by fred
Modified: 2012-01-31 21:57 UTC (History)
3 users (show)

Fixed In Version: rygel-0.12.7-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-31 21:57:32 UTC


Attachments (Terms of Use)
File: dso_list (5.85 KB, text/plain)
2011-12-01 16:51 UTC, fred
no flags Details
File: backtrace (1.11 MB, text/plain)
2011-12-01 16:51 UTC, fred
no flags Details
File: smolt_data (4.61 KB, text/plain)
2011-12-01 16:51 UTC, fred
no flags Details
File: maps (25.54 KB, text/plain)
2011-12-01 16:51 UTC, fred
no flags Details

Description fred 2011-12-01 16:51:36 UTC
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/bin/rygel
comment:        started rhytmbox, tried to play a tune, which triggered a codec download, and the, the error popped.
crash_function: signal_emit_unlocked_R
executable:     /usr/bin/rygel
kernel:         3.1.2-1.fc16.x86_64
pid:            1480
pwd:            /
reason:         Process /usr/bin/rygel was killed by signal 11 (SIGSEGV)
time:           jeu. 01 déc. 2011 17:45:20 CET
uid:            1000
username:       fred

backtrace:      Text file, 1164798 bytes
dso_list:       Text file, 5986 bytes
maps:           Text file, 26151 bytes
smolt_data:     Text file, 4725 bytes

environ:
:SHELL=/bin/zsh
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-nhCKEiILFd,guid=5ac62768647112903af665a00000001e
:XDG_SESSION_COOKIE=a7abb38d09e3d8a83ae27fac00000009-1322731924.621930-1849830886
:XDG_RUNTIME_DIR=/run/user/fred
:DISPLAY=:0
:DESKTOP_SESSION=gnome
:LC_MEASUREMENT=fr_FR.utf8
:SSH_AUTH_SOCK=/tmp/keyring-5Eg8GJ/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1224,unix/unix:/tmp/.ICE-unix/1224
:LC_MONETARY=fr_FR.utf8
:LC_NUMERIC=fr_FR.utf8
:LC_TIME=fr_FR.utf8
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:GDMSESSION=gnome
:XDG_VTNR=1
:USERNAME=fred
:XDG_SESSION_ID=2
:GPG_AGENT_INFO=/tmp/keyring-5Eg8GJ/gpg:0:1
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-nhCKEiILFd,guid=5ac62768647112903af665a00000001e
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-fred-4gXmfy/database
:USER=fred
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1219
:SHLVL=1
:GDM_LANG=fr_FR.utf8
:PWD=/home/fred
:GNOME_KEYRING_CONTROL=/tmp/keyring-5Eg8GJ
:LANG=fr_FR.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=fred
:HOME=/home/fred

var_log_messages:
:Dec  1 17:45:20 boulet kernel: [25433.473040] rygel[1480]: segfault at 7fff7220bfa4 ip 0000003435420037 sp 00007fff7220bf70 error 6 in libgobject-2.0.so.0.3000.1[3435400000+4c000]
:Dec  1 17:45:21 boulet abrt[16273]: Saved core dump of pid 1480 (/usr/bin/rygel) to /var/spool/abrt/ccpp-2011-12-01-17:45:20-1480 (91287552 bytes)

Comment 1 fred 2011-12-01 16:51:39 UTC
Created attachment 539282 [details]
File: dso_list

Comment 2 fred 2011-12-01 16:51:45 UTC
Created attachment 539283 [details]
File: backtrace

Comment 3 fred 2011-12-01 16:51:47 UTC
Created attachment 539284 [details]
File: smolt_data

Comment 4 fred 2011-12-01 16:51:48 UTC
Created attachment 539285 [details]
File: maps

Comment 5 Jens Georg 2011-12-02 14:03:29 UTC
I'm not sure if the codec installation can cause this. Were you downloading some media file in one of the watched directories perhaps?

Also what is rygel's used back here?

Comment 6 fred 2011-12-02 15:26:02 UTC
I'm not very knowledgeable about rygel, since I installed it to see what it could do, but never actually used it to share any media.
I was not downloading anything in the watched folders.
Unfortunately, this is all the info I could gather related to the crash. Also, but this might be far fetched, I happened to install firewalld a few days before.
I'll try to reproduce the bug though. Maybe I'll pinpoint a better cause for the crash.

Comment 7 fred 2011-12-02 15:27:33 UTC
yep, I can definitely reproduce the issue.

Comment 8 Jens Georg 2011-12-02 15:36:40 UTC
Interesting. Thank you.

Comment 9 fred 2011-12-06 10:01:06 UTC
rhythmbox definitely clashes with rygel. After checking my configuration, it appears that there is an activated plugin under rhytmbox, the "D-BUS MediaServer 2 interface" . It might be related. Hope it helps anyway.

Comment 10 Jens Georg 2011-12-07 12:23:22 UTC
It does not clash, the DBus plugin is supposed to expose your Rhythmbox collection by UPnP via Rygel.

So either the plugin itself causes the endless loop or it triggers a bug in Rygel.

Comment 11 Jens Georg 2011-12-10 11:25:56 UTC
can you add the exact steps to reproduce? I only get import errors about missing plugins but no dialog asking for installation of that.

Comment 12 Jens Georg 2011-12-10 11:58:24 UTC
Ah, never mind. Has nothing to do with the decoder, apart from the fact that it triggers an update in Rhythmbox's MediaServer2 plugin and for some reason a container which is its own parent is created causing an infinite recursion.

Comment 13 Jens Georg 2012-01-17 13:19:07 UTC
This is two issues:
One is that rhythmbox sends too many updates and the other is that rygel isn't particularily forgiving when rhythmbox does this.

Comment 14 Jens Georg 2012-01-18 16:53:46 UTC
commit 595c62862cab37fda83d0bf31e8309c907fe13d6
Author: Jens Georg <mail@jensge.org>
Date:   Wed Jan 18 17:37:47 2012 +0100

    external: Don't crash on hierarchical update
    
    If a MediaServer2 provider sends an update for /foo/bar/baz and
    /foo/bar chances are that the update for /foo/bar invalidates the
    parent pointer in /foo/bar/baz causing a crash of various sorts.
    
    Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=759206

Will probably do a 0.12.6 later today.

Comment 15 Jens Georg 2012-01-19 10:43:44 UTC
Released as 0.12.7 and later today in 0.13.1 as well

Comment 16 Fedora Update System 2012-01-19 13:34:10 UTC
rygel-0.12.7-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rygel-0.12.7-1.fc16

Comment 17 Fedora Update System 2012-01-19 21:57:29 UTC
Package rygel-0.12.7-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rygel-0.12.7-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0693/rygel-0.12.7-1.fc16
then log in and leave karma (feedback).

Comment 18 Fedora Update System 2012-01-31 21:57:32 UTC
rygel-0.12.7-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.