Bug 75930 - IOError: profiles//default/resolv.conf
IOError: profiles//default/resolv.conf
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: rcn-7.3
  Show dependency treegraph
 
Reported: 2002-10-15 00:11 EDT by Jean-David Beyer
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-25 05:15:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-David Beyer 2002-10-15 00:11:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
When I change the telephone number for a ppp connection, I get a message dump.

Version-Release number of selected component (if applicable):
redhat-config-network-1.0.0-1

How reproducible:
Always

Steps to Reproduce:
1.GnomeFoot->Programs->System->NetworkConfiguration
2.Enter root password
3.Select ppp0 connection and press Edit
4.Select Provider tab
5.Change telephone number
6.Get traceback below.
7.If you ignore traceback and try to dial ppp0 connection, nothing seems to happen.

Reproducibility note: If I try again, I do not get the traceback, but something
is still wrong as it will not dial. I get a few dialog boxes complaining about
that resolv.conf file.

Note: I changed the same telephone number on a friend's computer running R.H.L.
7.3 and it worked fine there. As far as I know, my system is up to date as far
as up2date is concerned (and there is a new up2date on that machine). 

I am sending this from a different machine where I have not attempted to change
the number because it is not necessary to change it.
	

Actual Results:  Got traceback below. The number must be partly changed, because
if I re-run the steps above, the number that comes up is the changed one. System
does not appear to dial the number (or any number).

Expected Results:  Should have changed telephone number and it should work. I
wonder about the double slash between ...profiles//default/resolv.conf. It is
curious because that resolv.conf does not contain the telephone number anyway.

Additional info:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 449, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 289, in save
    self.saveProfiles()
  File "/usr/sbin/neat", line 308, in saveProfiles
    profilelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCProfileList.py",
line 302, in save 
    dnsconf.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 565,
in write
    Conf.write(self)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 277,
in write
    self.file = open(self.filename, 'w', -1)
IOError: [Errno 13] Permission denied:
'/etc/sysconfig/networking/profiles//default/resolv.conf' 

Local variables in innermost frame:
self: <netconfpkg.Conf.ConfEResolv instance at 855a5e8>
~
Comment 1 Jean-David Beyer 2002-10-26 10:04:53 EDT
Not a bug? Then what is it? After letting up2date update my other machine,
it too does not work, but it is the eth0 that does not work. The networking
seems to slowly deteriorate as up2date applies updates. I have not yet
figured out what files get deleted by these updates, but it is a royal PITA.
Comment 2 Harald Hoyer 2003-03-25 05:15:01 EST
see #67498

Note You need to log in before you can comment on or make changes to this bug.