Bug 759302 - libcmpiCppImpl0 package has a conflict with tog-pegasus
Summary: libcmpiCppImpl0 package has a conflict with tog-pegasus
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sblim-cmpi-devel
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Vitezslav Crhonek
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-01 23:20 UTC by Johnny Hughes
Modified: 2016-04-26 13:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-02 11:35:44 UTC


Attachments (Terms of Use)

Description Johnny Hughes 2011-12-01 23:20:57 UTC
Description of problem:
The tog-pegasus package and the libcmpiCppImpl0 package both provide:

/usr/lib64/libcmpiCppImpl.so

(or /usr/lib/libcmpiCppImpl.so for i386 arch)

This prevents them from being installed at the same time.

Comment 3 Daniel Veillard 2012-02-14 03:33:58 UTC
  Hi Johnny,

can you tell me a bit more about how you ended up with this issue.
libcmpiCppImpl0 is not a package as far as I can tell, only
libcmpiutil is, I assume that was the package where you had a conflict
which is surprizing. Could you tell me which version of 
  libcmpiutil
  libvirt-cim
  tog-pegasus

led to that problem ?

 thanks in advance,

Daniel

Comment 5 Daniel Veillard 2012-05-30 01:45:18 UTC
In the absence of feedback to my question in comment #c3 I think we should
close that bug as this issue wasn't reproduced by us and we can't guess
what actually happened,

  Reopen if one can reproduce and give the details,

   thanks,

Daniel

Comment 6 Shahriar Kent Ghadishah 2012-06-05 00:39:07 UTC
For reference purposes:

The RPM file for the libcmpiCppImpl0 package is libcmpiCppImpl0-2.0.1-5.el6.x86_64.rpm.

Comment 7 Gabriel 2012-06-11 17:41:14 UTC
In my case:

Error: tog-pegasus-libs conflicts with libcmpiCppImpl0-2.0.1-5.fc17.i686
Error: libcmpiCppImpl0 conflicts with 2:tog-pegasus-2.11.1-7.fc17.i686
Installed Packages
tog-pegasus.i686       2:2.11.1-5.fc17     @anaconda-0
tog-pegasus-libs.i686    2:2.11.1-5.fc17     @anaconda-0
libcmpiCppImpl0.i686     2.0.1-5.fc17     @anaconda-0

My guess is that this issue came from the preupgrade utility, since we got the @anaconda-0 parammeter. I had done the upgrade long time ago from fc15 to 16 and now from 16 to 17.

I did the same on another computer and this issue did not come up. In this installation, the one with this bug, I had a kernel issue after the upgrade, it was running the previous kernel and therefore I had to run some yum's in order to complete the upgrade.

I removed the package and it told me it also removed sblim-cmpi-dns version 1.0-5.fc17 also from @anaconda-0.

This seems to have done it. My question now is what was this package? I hope it doesn't mean some kind of security threat.

Comment 8 Clinton 2012-10-08 16:36:20 UTC
I got this error by following the following steps:

Install RHEL 6.2 from DVD iso.
After the installation:

yum install "*"

The goal was to install all RPMS so that I could use RHN to build a security patch bundle.

When checking what is installed, verses what is planned to be installed:

[root@clifishe-lnx2 foo]# rpm -qa | grep libcmpi
[root@clifishe-lnx2 foo]# rpm -qa |grep tog-p
tog-pegasus-libs-2.11.0-2.el6.x86_64
tog-pegasus-2.11.0-2.el6.x86_64


So, tog-pegasus is already installed at the time when it wants to install these two:

libcmpiCppImpl0-2.0.1-5.el6.i686 
libcmpiCppImpl0-2.0.1-5.el6.x86_64

Comment 9 Clinton 2012-10-08 16:42:13 UTC
The only yum repo I have in place at the time is from the DVD iso.

[root@clifishe-lnx2 foo]# yum whatprovides libcmpiCppImpl0 | grep libc | cut -d: -f1 | sort | uniq
libcmpiCppImpl0-2.0.1-5.el6.i686 
libcmpiCppImpl0-2.0.1-5.el6.x86_64 

The yum repos are created from the RHEL 6.2 Workstation DVD iso downloaded in Aug 2012.

Comment 10 RHEL Product and Program Management 2012-10-08 16:58:04 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 12 Kurt Seifried 2012-12-16 07:55:26 UTC
I can confirm this on RHEL 6.3 up to date:

# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.3 (Santiago)

# rpm -ql tog-pegasus-libs | grep libcmpiCppImpl
/usr/lib64/libcmpiCppImpl.so
/usr/lib64/libcmpiCppImpl.so.1

which of course conflicts with libcmpiCppImpl0:

# rpm -qpl libcmpiCppImpl0-2.0.1-5.el6.x86_64.rpm
/usr/lib64/libcmpiCppImpl.so
/usr/lib64/libcmpiCppImpl.so.0
/usr/lib64/libcmpiCppImpl.so.0.0.0

From the tog-pegasus Makefile.Release:

ifeq ($(PEGASUS_ENABLE_CMPI_PROVIDER_MANAGER),true)
PEGASUS_LIBRARIES += \
   libcmpiCppImpl
PEGASUS_PROVIDER_MANAGERS += \
   libCMPIProviderManager
endif

Comment 13 Michal Privoznik 2013-08-06 14:26:23 UTC
While this bug is valid, it has nothing to do with libcmpiutils component but sblim-cmpi-devel.

Comment 14 Vitezslav Crhonek 2013-08-07 12:22:17 UTC
/usr/lib64/libcmpiCppImpl.so packed in tog-pegasus-libs differs from /usr/lib64/libcmpiCppImpl.so packed in libcmpiCppImpl0. Both libraries are needed (but not at the same time - usually user of SFCB CIMOM installs libcmpiCppImpl0 package, user of OpenPegasus CIMOM installs tog-pegasus-libs) -> packages conflict. This is not a bug, it's intention.

But /usr/lib64/libcmpiCppImpl.so on the OpenPegasus side has been moved from tog-pegasus package to tog-pegasus-libs subpackage and that was not updated in sblim-cmpi-devel spec file. Currently sblim-cmpi-devel conflicts with tog-pegasus, but it should conflict with tog-pegasus-libs. This is bug and it's tracked in bz988239. May I close this as a duplicate or there's something I'm missing?

Comment 15 Leonard 2013-08-20 14:07:38 UTC
I do not seem to have access to BZ988239. I too am having this issue.

Comment 16 RHEL Product and Program Management 2013-10-14 00:53:34 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 17 Vitezslav Crhonek 2014-07-02 11:35:44 UTC
Closing, the conflict is intentional, see comment#14.


Note You need to log in before you can comment on or make changes to this bug.