Bug 759361 - NetKVMConfig tools can not change the rx and tx parameters shown in device manager in Win7
Summary: NetKVMConfig tools can not change the rx and tx parameters shown in device ma...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Yvugenfi@redhat.com
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 580954
TreeView+ depends on / blocked
 
Reported: 2011-12-02 06:02 UTC by Joy Pu
Modified: 2012-06-20 11:58 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: NetKVMConfig utility was not updating rx and tx parameters in Registry. Consequence: users cannot update rx and tx parameters in Registry with NetKVMConfig utility. Fix: correct NetKVMConfig parameters changing handler Result: NetKVMConfig works as expected.
Clone Of:
Environment:
Last Closed: 2012-06-20 11:58:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0751 0 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2012-06-19 19:31:22 UTC

Description Joy Pu 2011-12-02 06:02:59 UTC
Description:
Try to config virtio nic parameters with NetKVMConfig, check with the tools and it report the value has changed. But the change is not shown in the windows device manager. It is the same that if I change it from device manager, it will no influence the value get by NetKVmConfig tools.

Version-Release number of selected component (if applicable):
kernel: 
2.6.32-221
kvm&qemu: 
qemu-img-0.12.1.2-2.210.el6.x86_64
qemu-kvm-0.12.1.2-2.210.el6.x86_64
qemu-kvm-tools-0.12.1.2-2.210.el6.x86_64
qemu-kvm-debuginfo-0.12.1.2-2.210.el6.x86_64
gpxe-roms-qemu-0.9.7-6.7.el6.noarch


virtio-win:
virtio-win-1.4.0-1.el6.noarch



How reproducible:
always

Steps to Reproduce:
1. boot up a win7 guest
2. update the device driver for virtio nic
3. Set up KVMNetConfig tools
  - copy netkvmco.dll to system32
  - register it
    rundll32 netkvmco.dll,RegisterNetKVMNetShHelper
  - run netsh
    netsh netkvm show devices
    netsh netkvm show parameters 0
    netsh netkvm getparam 0 RxCapacity
    netsh netkvm setparam 0 RxCapacity 256
4. Check the parameters in device manager in Windows

Actual results:
In netsh tools it shows the parameter has changed, while the parameter is not changed in device manager
Expected results:
The parameter's value should be the same in both tools.

Additional info:

Comment 2 Yvugenfi@redhat.com 2011-12-26 16:06:41 UTC
1. The problem was found.

2. The utility changed default value instead of the parameter value in registry.

3. Keep in mind that device should be restarted in order for the parameters to take effect.

4. If advanced tab of device manager is opened while parameter is changed - it should be closed and reopened to see the change.

Comment 3 Ademar Reis 2012-01-05 15:41:16 UTC
How is NetKVMConfig packaged and tested? I want to clear the flags of this bug: it is in POST but has rhel6.3.0? and devel_ack? flags set, plus a cond-nak:capacity.

Comment 4 Yvugenfi@redhat.com 2012-01-08 12:25:41 UTC
NetKVMConfig is part of the NetKVM package according to WHQL requirements (we have to provide command line configuration tool if the driver has configuration options).

It was tested by the QE teem according to test and user documents provided to them by me (they are also part of the code repository).

It was decided that the bug priority is minor, because at least for now the only usage for this tool is to comply to MS checklist (although in the future this toll can be used for our network driver configuration). Nevertheless the problem that caused the bug was found and fixed - and the fix will be release with next build of Windows virtio drivers.

Comment 7 Joy Pu 2012-03-13 11:49:15 UTC
Try the same steps in Win7 with virtio-win-prewhql-0.1-23. The Tx and Rx value from netsh netkvm and device manager is the same. Bug verified.

Comment 8 Vadim Rozenfeld 2012-05-03 10:32:27 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:  NetKVMConfig utility was not updating rx and tx parameters in Registry.
Consequence: users cannot update rx and tx parameters in Registry with NetKVMConfig utility.
Fix: correct NetKVMConfig parameters changing handler
Result: NetKVMConfig works as expected.

Comment 9 errata-xmlrpc 2012-06-20 11:58:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0751.html


Note You need to log in before you can comment on or make changes to this bug.