Bug 75940 - During bootup, DHCP fails to obtain dynamic IP
During bootup, DHCP fails to obtain dynamic IP
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 02:22 EDT by Fox Napier
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-15 12:05:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fox Napier 2002-10-15 02:22:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Hello,
I have installed a fresh stock installation of Redhat Linux 8.0 onto a Dell 
Inspiron 5000e laptop with a 3Com FE575C-10/100 PCMCIA network card.  
Unfortunately at bootup, it fails to initialize an address for 3Cxxx but then 
PCMCIA loads up and after logging on I get a dynamic IP connection.  However, 
since my IP was not assigned from the beginning, the rest of the system does 
not know my hostname and I am called "localhost.localdomain".  In RH 7.3, I was 
given my machine name immediately.

I believe I know what the problem may be, but do not know how to fix it.  I 
encountered this problem with an a RH 6.2 network install as well.  Briefly, 
the order of loading the modules for a laptop are incorrect.  Before DHCP is 
requested or any communication is tried, the PCMCIA module should be loaded to 
initialize the 3Com card.  Right now, that is not happening so DHCP fails to 
find 3Cxxx.  If someone can change it to the correct order (as in the one found 
in RH 7.3) that would be great.

I suspect the cause of this is the RH 8.0 installer lumping the installation 
type of a desktop and a laptop into "Personal Desktop"
Previously in the 7.3 installer, Laptop had its own option.  So, I'm guessing 
the way laptop network cards are initialized is different from desktop cards.

Also, as a side note, I run my lcd at 1600x1200 and the X probing for this in 
the install program are still broken.  Had to edit XFree86-Config manually and 
put in the proper Monitor settings.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Turn on system
2.Wait to see 3Cxxx fail
3.Hear PC Speaker beeps as PCMCIA initializes, 3Com card initializes and light 
on dongle goes on.
	

Actual Results:  I eventually got assigned a dynamic IP and could connect to 
the network.  But the system still displayed localhost.localdomain and not the 
new name I was given.  It hasn't been a problem for me yet but I've had friends 
who can't get an IP at all after this failure.

Expected Results:  As in RH 7.3 I should have been given a machine name.  

Additional info:
Comment 1 Daniel Walsh 2003-01-15 12:05:40 EST
You can edit /etc/sysconfig/network and add a line like the following
HOSTNAME=danlaptop.boston.redhat.com

The problem is that we have customers that require PCMCIA to be started after
network.

Dan

Note You need to log in before you can comment on or make changes to this bug.