Bug 759411 - classpathjx-mail-1.1.1 is buggy, update available since ~ 4 years
classpathjx-mail-1.1.1 is buggy, update available since ~ 4 years
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: classpathx-mail (Show other bugs)
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Java maintainers
BaseOS QE - Apps
: Rebase
Depends On:
  Show dependency treegraph
Reported: 2011-12-02 05:48 EST by Boris Folgmann
Modified: 2016-07-22 02:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-07-22 02:15:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Boris Folgmann 2011-12-02 05:48:11 EST
We want to migrate Java web apps from RHEL4 to RHEL6. I thought it is no longer necessary to use RPMs from jpackage.org. But now I found out that you released fairly old versions even with RHEL 6.1? How does this make sense?

classpathx-mail-1.1.1 has bugs. Our software works with 1.1.2 which is out for years, but it is not in RHEL 6.1 :-(

classpathx-mail-1.1.2 was released by GNU in April 2007!!
jpackage.org released a classpathx-mail-1.1.2 RPM in March 2009.

Here's one of the problems, when doing searches in folders of cyrus-imapd:

Exception in thread "main" javax.mail.MessagingException: Missing required argument to Search or;
  nested exception is: 
	gnu.inet.imap.IMAPException: Missing required argument to Search or
	at gnu.mail.providers.imap.IMAPFolder.search(IMAPFolder.java:891)
	at gnu.mail.providers.imap.IMAPFolder.search(IMAPFolder.java:840)
	at bouncechecker.BounceCheckerCLI.main(BounceCheckerCLI.java:26)
nested exception is:
gnu.inet.imap.IMAPException: Missing required argument to Search or
	at gnu.inet.imap.IMAPConnection.search(IMAPConnection.java:1442)
	at gnu.mail.providers.imap.IMAPFolder.search(IMAPFolder.java:875)
	at gnu.mail.providers.imap.IMAPFolder.search(IMAPFolder.java:840)
	at bouncechecker.BounceCheckerCLI.main(BounceCheckerCLI.java:26)
Java Result: 1

Please release the latest version as an update!
Comment 2 Andrew Overholt 2011-12-02 14:57:32 EST
I'm not knowledgeable on the subject, but what's the difference between the JARs provided by classpathx-mail and javamail?  Looking at the JAR contents, I see a bunch of class differences but also a lot of similarities.  What am I missing?
Comment 3 Alexander Kurtakov 2011-12-05 08:23:55 EST
Classpathx-mail was the only implementation back in the days of gcj. Sadly for RHEL 6 we did not manage to get the Sun's javamail implementation properly packaged. Because of that Sun's javamail didn't make it to RHEL 6. Classpathx-mail was neglected for very long time both package and upstream hence noone even looked at updating it.
Comment 5 Suzanne Yeghiayan 2012-02-14 18:22:26 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
Comment 6 Stanislav Ochotnicky 2012-06-20 11:49:49 EDT
You can either wait for this rebase request to be granted or file specific bugs you are encountering with this package in your configuration/use cases.
Comment 8 Alexander Kurtakov 2015-10-21 15:18:07 EDT
I really think this should be closed as wontfix considering how different javamail and classpathx-mail are. Exchanging one for the other at this phase of the support cycle should be a no go.
Comment 10 Mikolaj Izdebski 2016-07-22 01:37:54 EDT
Red Hat Enterprise Linux version 6 is entering the Production 2 phase of its lifetime and this bug doesn't meet the criteria for it, i.e. only high severity issues will be fixed. Please see https://access.redhat.com/support/policy/updates/errata/ for further information.
Comment 11 RHEL Product and Program Management 2016-07-22 02:15:42 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.