Bug 75947 - (440GX IRQ_ROUTING)Finish Redhat 8.0 install,boot AIC7XXX hang on 440GX chipset
(440GX IRQ_ROUTING)Finish Redhat 8.0 install,boot AIC7XXX hang on 440GX chipset
Status: CLOSED DUPLICATE of bug 79752
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 74937 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 04:00 EDT by Sunose
Modified: 2007-04-18 12:47 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sunose 2002-10-15 04:00:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0

Description of problem:
When Finish Install Redhat 8.0 ,Boot box ,hang when aic7xxx modules load.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Redhat 8.0 server mode
2.boot box

	

Actual Results:  Very many information.
last is:
aic7xxx_abort returns 0x2002.
and scsi device set offline and so on.


Additional info:

Hardware:Scsi Adaptec AIC-7896 SCSI BIOS V2.20S1B1
         Channel A:ID 0 Seagate SCSI harddisk ULTRA2-LVD
                   ID 6 ESG-SHV SCA HSBP M10 ULTRA2-LVD
         single CPU PIII 750.
Comment 1 Arjan van de Ven 2002-10-15 04:19:38 EDT
is this a 440GX chipset machine ?
Comment 2 Sunose 2002-10-20 23:26:25 EDT
yes,this is a 440GX chipset machine
Comment 3 Arjan van de Ven 2002-10-21 03:57:18 EDT
440GX chipset machines are not supported very well in Red Hat Linux; but most
importantly you need to install the SMP kernel always due to a bios bug that
prevents the UP kernel from working!
Comment 4 Sunose 2002-10-22 22:17:53 EDT
I have been installed the smp kernel.
when boot with smp kernel.the machine be freeze when console print"
pty 2048 unix98 ptys configured"
Comment 5 Sunose 2002-10-22 22:38:29 EDT
Boot with smp kernel.and append noapic aic7xxx=no_probe,no_reset.
and get follow error message:
SCSI:aborting command due to timeout:pid scsi0,channel 0,id0,lun ....
Comment 6 Need Real Name 2002-10-30 16:39:59 EST
I have had this problem as well. The box is 
# lspci -v
00:00.0 Host bridge: Intel Corp. 440GX - 82443GX Host bridge
        Flags: bus master, medium devsel, latency 64
        Memory at f8000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [a0] AGP version 1.0

00:01.0 PCI bridge: Intel Corp. 440GX - 82443GX AGP bridge (prog-if 00 
[Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=03, sec-latency=64
        I/O behind bridge: 00002000-00002fff
        Memory behind bridge: f4200000-f42fffff
        Prefetchable memory behind bridge: fc000000-fdffffff

00:0c.0 SCSI storage controller: Adaptec AIC-7896U2/7897U2
        Subsystem: Adaptec: Unknown device 080f
        Flags: bus master, medium devsel, latency 32, IRQ 19
        BIST result: 00
        I/O ports at 1400 [disabled] [size=256]
        Memory at f4100000 (64-bit, non-prefetchable) [size=4K]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [dc] Power Management version 1

00:0c.1 SCSI storage controller: Adaptec AIC-7896U2/7897U2
        Subsystem: Adaptec: Unknown device 080f
        Flags: bus master, medium devsel, latency 32, IRQ 19
        BIST result: 00
        I/O ports at 1800 [disabled] [size=256]
        Memory at f4101000 (64-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 1

I exhchanged emails with Justin Gibbs who writes the aic7xxx driver, he 
said this:

> Kernel Free SCB list: 3 1 0
> scsi0: 0:1:0 command already completed

RH 8.0 broke interrupt routing to your aic7xxx controller.
There is nothing the driver can do if its interrupts don't work.
File a bug with RedHat.

I see someone else has found this problem and filed it.

I have tried the 2.4.18-14smp kernel, which stops the boot process at 
oprofile: APIC was already enabled

The machine is now up and running, sort of, using the rescue environment. 
For some reason the kernel or intird used there does not have the same 
problems as the installed kerne/initrd.

I have salvaged som dmesg-files if that is of interest.

This is a very bad situation as the machine needs to go back into 
production without delay.
Comment 7 Mark Gardiner 2002-11-22 01:15:28 EST
I have installed RH8.0 (bootnet) on my Intel ISP2150 (L440GX+ board with 
Adaptec AIC7896 SCSI BIOS v2.20S1B1).  One processor installed.

When booting 2.4.18-14smp it stalls at "oprofile: APIC was already enabled".

What should I do?
Comment 8 Sunose 2002-11-22 02:43:17 EST
Any temporary Solution for this issue?
Comment 9 Arjan van de Ven 2002-11-22 04:55:25 EST
you might be able to have more success with the i586 smp kernel
Comment 10 Need Real Name 2002-11-27 03:21:30 EST
I've got the same problem with a PIII 866 and 815EP chipset. 'Tried several different Adaptec 2940 
cards, 7871 7880 etc. - all have the identical abort error 0x2002 and fail to load. This also happens 
with the 2.4.18.18.7x kernel when upgrading from 2.4.9-34. My initial impression is that kudzu is 
broken but haven't had time to pursue it yet.
Comment 11 Sunil Kayiti 2002-12-01 17:47:08 EST
I have the same problem. Adaptec 7896 Ultra 2, BIOS version 6.2.8. The 
installation went smoothly, it loaded aic7xx and DAC960 drivers, but on 
bootup, it fails. I get an error message that modprobe failed to exec 
scsi_hostadapter and return 0x002. 

Any help appreciated. Thx
Comment 12 Need Real Name 2002-12-02 13:40:20 EST
See bigid 78243 for a workaround.
Comment 13 Need Real Name 2002-12-02 13:42:25 EST
Correction: Thats bug id 78234
Comment 14 Arjan van de Ven 2002-12-09 08:18:21 EST
*** Bug 74937 has been marked as a duplicate of this bug. ***
Comment 15 Alan Cox 2003-06-08 07:31:14 EDT

*** This bug has been marked as a duplicate of 79752 ***
Comment 16 Red Hat Bugzilla 2006-02-21 13:49:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.