Bug 759478 - An upgrade of gtk2 forgets keyboard shortcuts which contain <Control>
Summary: An upgrade of gtk2 forgets keyboard shortcuts which contain <Control>
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 768704
TreeView+ depends on / blocked
 
Reported: 2011-12-02 13:38 UTC by Enrique
Modified: 2012-01-05 20:58 UTC (History)
5 users (show)

Fixed In Version: libxfce4ui-4.8.1-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-31 20:25:09 UTC


Attachments (Terms of Use)
~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml (16.34 KB, text/plain)
2011-12-02 13:38 UTC, Enrique
no flags Details

Description Enrique 2011-12-02 13:38:43 UTC
Created attachment 539637 [details]
~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

Description of problem:

I recently upgraded xfwm4 to the last version of xfwm4  in updates-testing repository. I had some shortcuts defined which use the key <Control>. After the upgrade they stop working. If, however, I define a new shortcut which uses <Control>, then it works (now it seems to be called <Primary>.

 I attach a copy of my ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml file

Version-Release number of selected component (if applicable):

xfwm4-4.8.2-1.fc15.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Have a previous version of xfwm4 installed.
2. Define keyboard shortcuts with make use of <Control>
3. Update xfwm4 to xfwm4-4.8.2-1

Actual results:

The previously defined shortcuts won't work

Comment 1 Kevin Fenzi 2011-12-03 18:54:10 UTC
I wonder if this has anything to do with the recent gtk2 update. 

Did gtk2 update for you around the same time?
Adding christoph here for his thoughts.

Comment 2 Christoph Wickert 2011-12-05 00:32:44 UTC
At first I thought this was an xfwm4 bug as we had some trouble with it recently but now I do think it's indeed gtk. I updated to xfwm4-4.8.2-1.fc15.x86_64 and found out that <Control> + <Esc> as shortcut for xfce4-popup-menu is no longer working. Then I downgraded to 4.8.3-4 but the menu did not come back. And I updated to gtk2-2.24.7-3.fc15 on Tuesday, Nov 29, this falls exactly into the time window

Note that the Ctrl key is still working, but it's treated differently. What used to be <Control> has become <Primary>. Smells like gtk to be, but I need to investigate this further.

Comment 3 Christoph Wickert 2011-12-05 00:50:55 UTC
The gtk 2.24.7-3 update has removed a patch called "keycode-unbind.patch", see
http://pkgs.fedoraproject.org/gitweb/?p=gtk2.git;a=commitdiff;h=9100b9fee212

Sounds interesting although I haven't looked into it yet.

Comment 4 Enrique 2011-12-06 14:13:58 UTC
 Yes, actually at the same time as xfwm4 was updated  also gtk2 was upgraded to version 2.24.7-3.

Comment 5 Christoph Wickert 2011-12-10 10:19:48 UTC
(In reply to comment #3)
> The gtk 2.24.7-3 update has removed a patch called "keycode-unbind.patch", see
> http://pkgs.fedoraproject.org/gitweb/?p=gtk2.git;a=commitdiff;h=9100b9fee212

That patch was removed because it got upstreamed in 2.24.8. Still, gtk2 is the cuplrit here. Reassigning.

Comment 6 Christoph Wickert 2011-12-12 10:01:10 UTC
I have meanwhile tried gtk2-2.24.7-3 from koji: A single keytroke of the Ctrl key is now correctly treated as <Control_L> or <Control_R>, but in combination with other keys it becomes <Primary> again.

Comment 7 Matthias Clasen 2011-12-12 13:54:09 UTC
You probably mean 2.24.8-3. However, the patch in there does not change the part of the keyhandling code at all, so it would be quite surprising that you should see any difference.

Anyway, accelerators involving Control work fine in gtk2 applications that I am testing here, like the gimp, as well as in gtk-demo.

Comment 8 Christoph Wickert 2011-12-12 14:59:56 UTC
(In reply to comment #7)
> You probably mean 2.24.8-3. 

No, this bug was filed against F15 and 2.24.7-3.fc15 is the latest F15 build in koji. The bug we are talking about here was introduced in 2.24.7-1.fc15 and as AFAIK the keyhandling code was changed several times by Michael Natterer before 2.24.7 was released.

Comment 9 Fedora Update System 2011-12-19 17:59:25 UTC
libxfce4ui-4.8.0-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libxfce4ui-4.8.0-6.fc16

Comment 10 Fedora Update System 2011-12-19 17:59:50 UTC
libxfce4ui-4.8.0-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libxfce4ui-4.8.0-6.fc15

Comment 11 Fedora Update System 2011-12-22 22:36:05 UTC
Package libxfce4ui-4.8.0-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libxfce4ui-4.8.0-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17273/libxfce4ui-4.8.0-6.fc16
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2011-12-24 12:10:02 UTC
libxfce4ui-4.8.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libxfce4ui-4.8.1-1.fc15

Comment 13 Fedora Update System 2011-12-31 20:25:09 UTC
libxfce4ui-4.8.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2012-01-05 20:58:36 UTC
libxfce4ui-4.8.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.