Bug 75952 - Xmms won't play or add any file to a playlist
Xmms won't play or add any file to a playlist
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
8.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 04:18 EDT by Sensei
Modified: 2014-03-16 22:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-17 15:42:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sensei 2002-10-15 04:18:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Xmms does not play any file. It simply opens the "Open file" dialog, but after
choosing the file, it won't open the selected file at all.
The same fact happens when trying to add a file to a playlist.

If you open a hand-made playlist, it shows the files in the playlist window, but
when pressing the "Play" button, it won't play anything.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open/Play a file
2.Open a playlist
3.Add files to a playlist
	

Actual Results:  Nothing: it does not behave the way it should.

Expected Results:  Play a file, open a playlist, add files...

Additional info:
Comment 1 Bill Nottingham 2002-10-15 16:12:42 EDT
MP3 file?
Comment 2 Warren Togami 2002-10-31 22:14:36 EST
senseiwa@libero.it, were you attempting to play MP3 files?

If so please close this as NOTABUG because MP3 support was removed from Red Hat
8.0.  You can easily install the MP3 plugin for XMMS however with
http://www.gurulabs.com/files/xmms-mp3-1.2.7-13.p.i386.rpm
Comment 3 Dave O'Connor 2003-01-09 13:10:51 EST
Is it possible that someone make this easier to fix or atleast to find?

I was using xmms with a the xmms-mpg123 plugin and everything was working fine
but when i upgraded using up2date and everything stopped working. Its working
now though because of the file above but took a lot of searching.

Thanks
Comment 4 Dave O'Connor 2003-01-09 13:29:44 EST
Sorry i also meant to add that this affected .ogg files too.

None would play complaining about incorrect plugin but had worked before with
the same plugin.
Comment 5 Bill Nottingham 2003-01-09 15:32:26 EST
Hm, that error sounds more like audio configuration rather than the MP3 plugin
issue. What was the exact error?
Comment 6 Dave O'Connor 2003-01-13 09:11:03 EST
hmmm, i'm getting the same thing with the new plugin on both mp3 and .ogg files.

The error msg is the same as the one you get when trying to play mp3's from xmms
in its pre-plugged-in state. i.e. the same as before you get plugin.

Can't recreate it. Used to happen when moving from one song in the playlist to
another but if you clicked on the play button it would play. Nothing major but a
little annoying :)

Thanks
Dave
Comment 7 Collin Starkweather 2003-01-17 13:20:47 EST
I second Dave O'Connor's comment.  Playing an MP3 is perhaps one of the most
common things people do.  I experienced the same problem and I ended up (1)
going to Red Hat's site (2) finding Bugzilla (3) signing up for a Bugzilla
account and (4) running 2 bug queries before I figured out the nature of my bug.
 I can't believe I spent this much time just trying to figure out how to play
MP3s with my new Red Hat distro.  Pardon the rant, but 

<rant>
Does Red Hat think that most customers will be this patient?  XMMS is open
source, after all.  Red Hat engineers could have added a few lines of code that
would prevent XMMS from failing silently; e.g., a dialog to inform the user
"sorry but the MP3 plugin is not installed ... you need to blah blah blah ..."
prior to officially removing support for MP3s.  

It would save thier engineers lots of time dealing with bug reports like this,
but more importantly, it would save customers like me time troubleshooting
something as basic as an MP3 player.  Heck, an engineer spending a week on the
problem would probably make Red Hat 6 months of an engineer's salary over the
next several years in the income that was not lost to impatient users getting
frustrated with things like this and just giving up.

I realize Red Hat is not focused on the desktop, but they are leaning
progressively in the direction of trying to capture some desktop space.  Imagine
talking a Windows user into giving Linux a shot.  What's one of the first things
they're going to do?  Try to play their MP3s!
</rant>
Comment 8 Bill Nottingham 2003-01-17 15:42:05 EST
a) this is all documented in the release notes
b) there is a notification plugin; it just had an unfortunate bug
    in the 8.0 version, and it's been fixed for roughly 4 to 5 months now.

Comment 9 Dave O'Connor 2003-01-20 10:36:58 EST
I understand the legal standpoint but even the plugin you gave still causes the
problem sometimes.

/me looks around dazedly :)

Note You need to log in before you can comment on or make changes to this bug.