Bug 75959 - Python 2.2.2 is released :-)
Summary: Python 2.2.2 is released :-)
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: python   
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Brock Organ
URL: http://www.python.org/2.2.2/
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-15 08:56 UTC by Need Real Name
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 20:36:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-15 08:56:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Please upgrade python 2.2.1 to 2.2.2

2.2.1 contains some nasty bugs, that under some circumstances, can cause a
segfault. Distributing 3rd party products, that expose this bug, to RH8.0 users
will be a pain otherwise :-P

It's a bugfix only release, so please upgrade.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. .
2. .
3. .
	

Additional info:

Comment 1 Mihai Ibanescu 2002-10-15 19:43:05 UTC
Do you have examples of ways 2.2.1 is broken? If there are compelling reasons to
release python, sure, will do.

Comment 2 Need Real Name 2002-11-12 20:37:42 UTC
Haven't check, if this really got fixed in Python 2.2.2, but if your file
contains non-english UTF-8 characters ...

[jylitalo@shoes photos]$ python
Python 2.2.1 (#1, Aug 30 2002, 12:15:30)
[GCC 3.2 20020822 (Red Hat Linux Rawhide 3.2-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import xml.dom.minidom
>>> doc = xml.dom.minidom.parse("/home/jylitalo/public_html/photos/catalog.phojo")
>>> print doc.toxml()

Traceback (most recent call last):
  File "<stdin>", line 1, in ?
UnicodeError: ASCII encoding error: ordinal not in range(128)
>>>


Comment 3 Need Real Name 2002-11-12 21:06:29 UTC
This _thread_ describes a bug in 2.2.1, that does happen in RH8.0 python2.2.2 
too. It causes python to segfault. 
 
http://lists.zope.org/pipermail/zodb-dev/2002-September/003254.html 
 
Other problems with 2.2.1 are here; 
 
https://sourceforge.net/tracker/index.php?func=detail&aid=636029&group_id=15628&atid=115628 
https://sourceforge.net/tracker/index.php?func=detail&aid=531607&group_id=15628&atid=115628 


Comment 4 Need Real Name 2002-11-12 21:07:31 UTC
Typo. 
 
Happens in that does happen in RH8.0 python2.2.1, not 2.2.2

Comment 5 Mihai Ibanescu 2002-11-25 22:02:12 UTC
Not exactly the same thing, but rawhide should have 2.2.2 packages available.
Until rawhide catches up, here's a link where you can test these pacakges:

ftp://people.redhat.com/misa/fixes/python

Comment 6 Jack Moffitt 2002-11-26 05:27:20 UTC
Python 2.2.2 also includes enhanced MIME handling in the email package of the
standard library that is not in 2.2.1.  I've already run into a program that
failed to run on RH8.0 because of this.  Specifically it imported the
email.MIMEMultipart module, which is new in 2.2.2.

Comment 7 Bill Nottingham 2006-08-04 20:36:56 UTC
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.


Note You need to log in before you can comment on or make changes to this bug.