This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 759593 - rocs 4.7.80-1 not built with $RPM_OPT_FLAGS
rocs 4.7.80-1 not built with $RPM_OPT_FLAGS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rocs (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2011-12-02 14:21 EST by Ville Skyttä
Modified: 2011-12-02 19:35 EST (History)
6 users (show)

See Also:
Fixed In Version: rocs-4.7.80-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-02 19:35:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2011-12-02 14:21:28 EST
rocs 4.7.80-1 is not built with $RPM_OPT_FLAGS:

http://kojipkgs.fedoraproject.org/packages/rocs/4.7.80/1.fc17/data/logs/x86_64/build.log

4.7.4-1 does not have this problem:

http://kojipkgs.fedoraproject.org/packages/rocs/4.7.4/1.fc16/data/logs/x86_64/build.log
Comment 1 Kevin Kofler 2011-12-02 17:53:03 EST
I'm investigating. I suspect upstream must have made some broken change to its CMakeLists.txt files.
Comment 2 Kevin Kofler 2011-12-02 17:55:23 EST
This commit is incorrect:
https://projects.kde.org/projects/kde/kdeedu/rocs/repository/revisions/43b6ccf22174629ebec0a0579365c4269cf0fb58/diff/CMakeLists.txt

This overwrites CMAKE_CXX_FLAGS instead of adding to it.
Comment 3 Kevin Kofler 2011-12-02 18:00:37 EST
That line should be:
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${KDE4_ENABLE_EXCEPTIONS}" )

I'm going to patch this in Rawhide ASAP and then push that trivial fix upstream.
Comment 4 Kevin Kofler 2011-12-02 18:15:15 EST
Should be fixed in rocs-4.7.80-2.fc17.
Comment 5 Kevin Kofler 2011-12-02 18:20:40 EST
Grrr, this fails to build with the proper flags:

CMakeFiles/rocs_assignvaluesplugin.dir/assignvalueswidget.o: In function `AssignValuesWidget::assignValues()':
/builddir/build/BUILD/rocs-4.7.80/src/Plugins/AssignValues/assignvalueswidget.cpp:104: undefined reference to `ValueModifier::ValueModifier()'
/builddir/build/BUILD/rocs-4.7.80/src/Plugins/AssignValues/assignvalueswidget.cpp:113: undefined reference to `ValueModifier::enumerate(QList<boost::shared_ptr<Data> >, int, bool)'
/builddir/build/BUILD/rocs-4.7.80/src/Plugins/AssignValues/assignvalueswidget.cpp:116: undefined reference to `ValueModifier::enumerate(QList<boost::shared_ptr<Pointer> >, int, bool)'
/builddir/build/BUILD/rocs-4.7.80/src/Plugins/AssignValues/assignvalueswidget.cpp:139: undefined reference to `ValueModifier::assignRandomReals(QList<boost::shared_ptr<Data> >, double, double, int, bool)'
/builddir/build/BUILD/rocs-4.7.80/src/Plugins/AssignValues/assignvalueswidget.cpp:104: undefined reference to `ValueModifier::~ValueModifier()'
/builddir/build/BUILD/rocs-4.7.80/src/Plugins/AssignValues/assignvalueswidget.cpp:126: undefined reference to `ValueModifier::assignRandomIntegers(QList<boost::shared_ptr<Data> >, int, int, int, bool)'
/builddir/build/BUILD/rocs-4.7.80/src/Plugins/AssignValues/assignvalueswidget.cpp:129: undefined reference to `ValueModifier::assignRandomIntegers(QList<boost::shared_ptr<Pointer> >, int, int, int, bool)'
/builddir/build/BUILD/rocs-4.7.80/src/Plugins/AssignValues/assignvalueswidget.cpp:142: undefined reference to `ValueModifier::assignRandomReals(QList<boost::shared_ptr<Pointer> >, double, double, int, bool)'
/builddir/build/BUILD/rocs-4.7.80/src/Plugins/AssignValues/assignvalueswidget.cpp:104: undefined reference to `ValueModifier::~ValueModifier()'
Comment 6 Kevin Kofler 2011-12-02 18:22:23 EST
I think the problem here is that some export macro is missing, which upstream didn't notice because they were trashing the visibility flags. Grrr!
Comment 7 Kevin Kofler 2011-12-02 18:34:35 EST
Should be fixed now (and the fix also happens to fix compilation on Window$ even without my previous patch, because hidden visibility is the default there, so that gives me an excuse to commit the patch upstream as soon as I verified that it builds even though upstream is in Beta 2 tagging freeze :-p ).
Comment 8 Kevin Kofler 2011-12-02 19:35:52 EST
Fixed in rocs-4.7.80-2.fc17:
http://koji.fedoraproject.org/koji/getfile?taskID=3559418&name=build.log

Fixes pushed upstream, too.

Note You need to log in before you can comment on or make changes to this bug.