Bug 75960 - neat-control should be aware of current profile
Summary: neat-control should be aware of current profile
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-15 09:01 UTC by diego.santacruz
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:49:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Snapshot of neat-control showing the problem (21.05 KB, image/png)
2002-10-15 09:02 UTC, diego.santacruz
no flags Details

Description diego.santacruz 2002-10-15 09:01:14 UTC
Description of Problem:
neat-control should be aware of the current profile and show the
devices for the current profile accordingly. Currently if a device is
present in several profiles redhat-control-network will show the configs
as active in all profiles when the device has been activated in one
profile (see screenshot).

Version-Release number of selected component (if applicable):
redhat-config-network-1.1.20-1

How Reproducible:
Always

Steps to Reproduce:
1. configure a net device eth1 (nickname lts-lan) under profile "LAN"
2. configure a net device eth1 (nickname wireless) under profile "Wireless"
3. set profile to "LAN"
4. activate eth0

Actual Results:
Despite being under different profiles, both devices are shown (without any
mention of their profile nor the active profile). Furthermore both are shown as
active. See next snapshot.

Expected Results:
The current profile should be show.
The devices under the current profile only should be shown (maybe the devices
under other profiles should be shown but differently?).

Additional Information:
redhat-config-network-1.1.20-1

Comment 1 diego.santacruz 2002-10-15 09:02:01 UTC
Created attachment 80465 [details]
Snapshot of neat-control showing the problem

Comment 2 Jon DeSena 2002-11-04 16:18:44 UTC
See attached patch to bug #77267 for a solution to this.

Comment 3 Harald Hoyer 2003-01-13 12:25:47 UTC

*** This bug has been marked as a duplicate of 77267 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:49:58 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Comment 5 David Lawrence 2006-04-24 19:17:04 UTC
Adding to blocker bug 185483 and also adding IBM confidential group.

Comment 6 David Lawrence 2006-04-24 19:34:58 UTC
Oops. I am sorry for these changes. I searched on the wrong bug list and
mistakenly made these changes. Removing from blocker bug 185483 and also
removing IBM confidential group.


Note You need to log in before you can comment on or make changes to this bug.