Bug 759609 - Verbs do not appear when selecting Permission For All
Verbs do not appear when selecting Permission For All
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Tom McKay
SAM QE List
:
Depends On:
Blocks: 703617 765991
  Show dependency treegraph
 
Reported: 2011-12-02 15:41 EST by Eric Sammons
Modified: 2012-04-26 20:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 765991 (view as bug list)
Environment:
Last Closed: 2012-04-26 20:22:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2011-12-02 15:41:36 EST
Description of problem:
Trying to create a read-only permission for a specific Org does not appear possible with out a great deal of effort because Verb(s) do not appear when selecting Permission for +All.

Version-Release number of selected component (if applicable):
katello-headpin-all-0.1.110-1.el6.noarch

Steps to Reproduce:
1. Navigate to Administration/Roles
2. Create a New role
3. Add a Permission by first selecting the appropriate Org
4. Select +All next to Permission For:

  
Actual results:
Defaults to All All

Expected results:
Verbs should appear so that the sysadmin can be selective with regards to actions permitted for all, i.e. end result should be:

All/Access Environment Contents
    Access Organization
    Access Provider
    Access Activation Keys

Additional info:
Comment 1 Tom McKay 2011-12-16 10:44:27 EST
commit 5a8dd2bb95d32072696dc6b5184352ad00aa0fa6
Author: Tom McKay <thomasmckay@redhat.com>
Date:   Fri Dec 16 10:40:54 2011 -0500

    Bug 759609, 765991 - Verbs do not appear when selecting Permission For All
    https://bugzilla.redhat.com/show_bug.cgi?id=759609
    https://bugzilla.redhat.com/show_bug.cgi?id=765991
      + The existing description of what "+ All" means was not being displayed properly. This has been corrected.
      + TODO: There are likely larger workflow issues surrounding this part of the UI that need attention.
Comment 2 Eric Sammons 2011-12-20 12:37:11 EST
Verified

Note You need to log in before you can comment on or make changes to this bug.