This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 759633 - Text cursor and typing position become disjointed on first line of text
Text cursor and typing position become disjointed on first line of text
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-02 16:23 EST by Matt Reid
Modified: 2012-03-27 05:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 05:34:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/Xorg.0.log contents (47.82 KB, text/plain)
2011-12-09 09:13 EST, Matt Reid
no flags Details

  None (edit)
Description Matt Reid 2011-12-02 16:23:46 EST
Description of problem:
While using LibreOffice Writer today, I ran across an issue where whenever I added text to the first line in my document, the text cursor and where the characters appeared were disjointed by 5 or so characters to the left. If I went down a line, everything was fine, but if I moved (via arrows or clicking) back to the top line, again text entry was far behind where the cursor was.

Closing the document and reopening fixed it, but once it happened, it was consistent in the first line being strange, and the rest of the document seeming to be fine. Not sure if this might be a LibreOffice thing, or a rendering issue, or X or what have you.

Version-Release number of selected component (if applicable):
libreoffice-writer-3.4.4.2-3.fc16.x86_64

How reproducible:
Unfortunately, I have not been able to reproduce it, if there are any log files or anything that would be beneficial in trying to track this down, please let me know where they are located and I will provide them.

Steps to Reproduce:
Sorry, if I run across it again, I'll update.
  
Actual results:
Typing on the first line was confusing, as text was appearing (or disappearing) somewhere other than the text cursor. The actual text cursor seemed to be 5 or so characters to the left of the rendered text cursor.

Expected results:
Typing in a document as usual.

Additional info:
I was able to capture video of it - http://linuxgrrl.com/fedora-ux/Tmp/libreoffice.webm
Comment 1 David Tardon 2011-12-06 04:17:28 EST
No, there are no logs. And since you cannot reproduce it, I suppose there is not much we can do.
Comment 2 Caolan McNamara 2011-12-06 05:05:25 EST
If it only happened the once, then indeed hard to determine. Can you attach your /var/log/Xorg.0.log anyway, just so we can see what X driver this is, in case it becomes a pattern.
Comment 3 Matt Reid 2011-12-09 09:13:01 EST
Created attachment 544556 [details]
/var/log/Xorg.0.log contents
Comment 4 Caolan McNamara 2012-03-27 05:34:59 EDT
Can't do anything about this one unfortunately, as I can't reproduce it :-(

Note You need to log in before you can comment on or make changes to this bug.