Bug 759653 - SELinux is preventing /bin/bash from 'getattr' accesses on the file /etc/locale.conf.
Summary: SELinux is preventing /bin/bash from 'getattr' accesses on the file /etc/loca...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2a27d8cc0b8f35f06e783d62313...
: 759832 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-02 22:52 UTC by Illya
Modified: 2011-12-22 22:48 UTC (History)
7 users (show)

Fixed In Version: selinux-policy-3.10.0-67.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-22 22:48:50 UTC
Type: ---


Attachments (Terms of Use)
File: description (2.62 KB, text/plain)
2011-12-02 22:52 UTC, Illya
no flags Details

Description Illya 2011-12-02 22:52:06 UTC
libreport version: 2.0.7
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.1.2-1.fc16.x86_64
reason:         SELinux is preventing /bin/bash from 'getattr' accesses on the file /etc/locale.conf.
time:           Fr 02 Dez 2011 23:50:30 CET

description:    Text file, 2678 bytes

Comment 1 Illya 2011-12-02 22:52:09 UTC
Created attachment 539819 [details]
File: description

Comment 2 Daniel Walsh 2011-12-03 16:07:54 UTC
restorecon /etc/locale.conf 

Will fix the problem. Is this file created at boot time?

Comment 3 Illya 2011-12-03 20:12:10 UTC
No. It was created at install time.

Comment 4 Carl G. 2011-12-04 11:35:57 UTC
*** Bug 759832 has been marked as a duplicate of this bug. ***

Comment 5 Carl G. 2011-12-04 11:36:48 UTC
Weird, the DUPE share the same ABRT hash...

Comment 6 Daniel Walsh 2011-12-05 14:53:57 UTC
illya did you change your lanquage at firstboot?

Comment 7 Daniel Walsh 2011-12-05 14:54:57 UTC
mgrepl we should probably label this as locale_t and set up filename trans rules.

Comment 8 Illya 2011-12-05 15:58:27 UTC
(In reply to comment #6)
> illya did you change your lanquage at firstboot?

Yes. I've set my "user"-lang to german and used "Copy settings.." (?) in gnome-settings to set system-wide language.

> cat /etc/locale.conf 
> LANG=de_DE.utf8

Comment 9 Daniel Walsh 2011-12-05 20:41:52 UTC
Miroslav lets back port 

4be99793a0848a4659186e452f737e733062b019

Comment 10 Miroslav Grepl 2011-12-06 08:30:17 UTC
Added.

Comment 11 Fedora Update System 2011-12-15 17:08:37 UTC
selinux-policy-3.10.0-67.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-67.fc16

Comment 12 Fedora Update System 2011-12-16 20:00:16 UTC
Package selinux-policy-3.10.0-67.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-67.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17191/selinux-policy-3.10.0-67.fc16
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2011-12-22 22:48:50 UTC
selinux-policy-3.10.0-67.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.