Bug 75968 - Too many open files
Summary: Too many open files
Status: CLOSED DUPLICATE of bug 74989
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhpl   
(Show other bugs)
Version: 8.0
Hardware: i586
OS: Linux
high
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-15 10:47 UTC by petr
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-15 11:04:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description petr 2002-10-15 10:47:20 UTC
Description of problem:
After letting "Network configuration" window open for some time, python tracebak
appears saying that "Too many open files".

How reproducible:
Always, tested on 2 boxes with different configuration.

Steps to Reproduce:
1. Start Network configuration
2. Wait for some time
3. Traceback window appears saying:

Traceback (most recent calls last)
File "/usr/sbin/neat", line 774, in update_devicelist
File "/usr/sbin/../redhat-config-network/netconfpkg/Config.py", line 64, in __init__
File "/usr/sbin/../redhat-config-network/netconfpkg/Config.py", line 64, in load
OSError: Too many open files

Even the traceback is not possible to save, the only solution is to kill the
python process.

lsof shows 1024 lines of:
neat      1260    root 1019u  sock        0,0             81880 can't identify
protocol
neat      1260    root 1020u  sock        0,0             81881 can't identify
protocol
neat      1260    root 1021u  sock        0,0             82380 can't identify
protocol
neat      1260    root 1022u  sock        0,0             82381 can't identify
protocol
neat      1260    root 1023u  sock        0,0             82392 can't identify
protocol

Process 1260 is:
root      1260  0.0  2.8 22664 14724 ?       S    11:09   0:01 /usr/bin/python2.

Comment 1 Harald Hoyer 2002-10-15 11:04:55 UTC

*** This bug has been marked as a duplicate of 74989 ***


Note You need to log in before you can comment on or make changes to this bug.